PTA(Advanced Level)1083.List Grades

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade's interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student's name and ID, separated by one space. If there is no student's grade in that interval, output NONE instead.

Sample Input 1:
4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100
Sample Output 1:
Mike CS991301
Mary EE990830
Joe Math990112
Sample Input 2:
2
Jean AA980920 60
Ann CS01 80
90 95
Sample Output 2:
NONE
思路
  • 用结构体数组存储数据,一次排序之后+一次遍历输出符合条件的人的信息就好了
代码
#include<bits/stdc++.h>
using namespace std;
struct student
{
	string name, id;
	int grade;
}a[10010];

bool cmp(student a, student b)
{
	return a.grade < b.grade;
}

int main()
{
	int n;
	cin >> n;
	for(int i=0;i<n;i++)
		cin >> a[i].name >> a[i].id >> a[i].grade;
	sort(a, a+n, cmp);
	int l, r;
	bool finded = false;     //表示是否至少有一个输出
	cin >> l >> r;
	if(l > r)   swap(l,r);
	for(int i=n-1;i>=0;i--)     //题目要求的是分数按高到低排,所以倒过来遍历
	{
		if(a[i].grade >= l && a[i].grade <= r)
		{
			finded = true;
			cout << a[i].name << " " << a[i].id << endl;
		}
	}
	if(!finded)
		cout << "NONE";
	return 0;
}


引用

https://pintia.cn/problem-sets/994805342720868352/problems/994805383929905152

原文地址:https://www.cnblogs.com/MartinLwx/p/11854791.html