Hdoj 1213.How Many Tables 题解

Problem Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

Author

Ignatius.L

Source

杭电ACM省赛集训队选拔赛之热身赛


思路

裸并查集题目,上模板就好了QAQ

代码

#include<bits/stdc++.h>
using namespace std;
int father[110];
void init(int n)
{
    for(int i=1;i<=n;i++) father[i]=i;
}
int find(int x)
{
    while(father[x]!=x) x=father[x];
    return x;
}
void join(int a,int b)
{
    int t1=find(a);
    int t2=find(b);
    if(t1!=t2) father[t1]=t2;
}
int getNum(int n)
{
	int num = 0;
	for(int i=1;i<=n;i++)
		if(father[i]==i)
			num++;
	return num;
}
int main()
{
	int t;
	cin >> t;
	while(t--)
	{
		int n,m;
		cin >> n >> m;
		init(n);
		for(int i=1;i<=m;i++)
		{
			int a,b;
			cin >> a >> b;
			if(find(a) != find(b))
				join(a,b);
		}
		cout << getNum(n) << endl;
	}
	return 0;
}
原文地址:https://www.cnblogs.com/MartinLwx/p/10042271.html