AtCoder Beginner Contest 171 A

A - αlphabet


Time Limit: 2 sec / Memory Limit: 1024 MB

Score : 100 points

Problem Statement

An uppercase or lowercase English letter αα will be given as input. If αα is uppercase, print A; if it is lowercase, print a.

Constraints

  • αα is an uppercase (A - Z) or lowercase (a - z) English letter.

Input

Input is given from Standard Input in the following format:

αα

Output

If αα is uppercase, print A; if it is lowercase, print a.


Sample Input 1 Copy

Copy
B

Sample Output 1 Copy

Copy
A

B is uppercase, so we should print A.


Sample Input 2 Copy

Copy
a

Sample Output 2 Copy

Copy
a

a is lowercase, so we should print a.

题意:输入一个字符,如果是大写字符输出 'A',如果是小写字符输出 'a'

代码如下:

#include<cstdio>
using namespace std;
int main(void)
{
    char c;
    while(~scanf("%c",&c))
    {
        getchar();
        if(c>='a'&&c<='z')
        puts("a");
        else //if(c>='A'&&c<)
        puts("A");
    }
    return 0;
 } 
原文地址:https://www.cnblogs.com/Mangata/p/13307870.html