HDU2795 Billboard 线段树

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1619    Accepted Submission(s): 809


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 


Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 


Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 


Sample Input
3 5 5 2 4 3 3 3
 


Sample Output
1 2 1 3 -1
 
  题目意思是给定一个高和宽的广告排,然后有N个人想在这上面张贴自己的广告,每个题提供的广告都是高为1,宽由他们定制的广告,求在满足先按行递增以及尽量满足左边空间的张贴方式,输出广告所在行。如果不能张贴的话,输出-1。
  该开始被题目的数据吓坏了,毕竟10^9不是小数目,又有线段树是典型的以空间换时间的数据结构,这不是以卵击石吗?还好,后面发现有一个数计较小,就是那个N,询问次数,最多才20万次询问,那么不就是说20万行以后的一定用不到吗(如果有超过20万行的话)?顺着这个思路就很好办了。
  每个节点除了保留其左右界(注意这里的左右界是对高度而言的,也即行的数目)之外,还保留一个能够容纳的最大宽度,这样就便于判定输出-1。
  代码如下:
#include <cstdio>
#include <cstring>
#include <cstdlib>
using namespace std;

struct Node
{
	int l, r, cnt, max;
}t[600005];

int w, h, n;

int Max( int x, int y )
{
	return x> y? x: y;
}

inline void getint( int &t )
{
    char c;
    while( c= getchar(), c< '0'|| c> '9' ) ;
    t= c- '0';
    while( c= getchar(), c>= '0'&& c<= '9' )
    {
        t= t* 10+ c- '0';
    }
}

void creat( int p, int l, int r )
{
	t[p].l= l, t[p].r= r;
	t[p].max= w, t[p].cnt= r- l; 
	if( r- l> 1 )
	{
		creat( p<< 1, l, ( l+ r )>> 1 );
		creat( ( p<< 1 )+ 1, ( l+ r )>> 1, r );
	}
}

int enquire( int p, int ww, int &ans )
{
	if( t[p].r- t[p].l== 1 )
	{
		ans= t[p].l;
		t[p].max-= ww;
		return t[p].max;
	}
	if( t[ p<< 1 ].max>= ww )
	{
		t[p].max= Max( t[ ( p<< 1 )+ 1 ].max, enquire( p<< 1, ww, ans ) );
	}
	else if( t[ ( p<< 1 )+ 1 ].max>= ww )
	{
		t[p].max= Max( t[ p<< 1 ].max, enquire( ( p<< 1 )+ 1, ww, ans ) );
	}
}

int main(  )
{
	while( scanf( "%d %d %d", &h, &w, &n )!= EOF )
	{
		if( h> 200000 )
		{
			if( n> 200000 )
			{
				creat( 1, 1, 200001 );
			}
			else
			{
				creat( 1, 1, n+ 1 );
			}
		}
		else
		{
			creat( 1, 1, h+ 1 );
		}
		for( int i= 1; i<= n; ++i )
		{
			int q, ans= 0;
			getint( q );
			if( q> t[1].max )
			{
				puts( "-1" );
				continue;
			}
			enquire( 1, q, ans );
			printf( "%d\n", ans );
		}
	}
	return 0;
}

  

原文地址:https://www.cnblogs.com/Lyush/p/2140375.html