HDU1372 Knight Moves BFS

Knight Moves

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2169    Accepted Submission(s): 1380


Problem Description

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.
 

Input

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.
 

Output

For each test case, print one line saying "To get from xx to yy takes n knight moves.".
 

Sample Input
e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6
 

Sample Output
To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.
 
  刚开始不知到题目是要干什么,后面百度百科什么是国际象棋才算懂了一点常识,这里就是在一个8*8的棋盘中给定两个点,行号用英文字母给定,列用数字给定,现在要问你的是一个骑士如何以最少的不少步数走到另外一个点。BFS,八个方向加上判定是否越界。
  代码如下:
#include <cstdio>
#include <cstring>
#include <queue>
#include <cstdlib>
using namespace std;

char map[25][25], hash[25][25];

struct Node
{
	int x, y, step;
}info;

int dir[8][2]= { -2, 1, 2, 1, 2, -1, -2, -1, 1, 2, 1, -2, -1, 2, -1, -2 };

bool legal( int x, int y )
{
	if( x< 1|| x> 8|| y< 1|| y> 8 )
	{
		return false;
	}
	return true;
}

int BFS( int sx, int sy )
{
	memset( hash, 0, sizeof( hash ) );
	info.x= sx, info.y= sy, info.step= 0;
	queue< Node >q;
	hash[sx][sy]= 1;
	q.push( info );
	while( !q.empty() )
	{
		Node pos= q.front();
		q.pop();
		if( map[ pos.x ][ pos.y ]== 2 )
		{
			return pos.step;
		}
		for( int i= 0; i< 8; ++i )
		{
			int x= pos.x+ dir[i][0], y= pos.y+ dir[i][1], step= pos.step+ 1;
			if( legal( x, y )&& !hash[x][y]  )
			{
				info.x= x, info.y= y, info.step= step;
				hash[x][y]= 1;
				q.push( info );
			}
		}
	}
}

int main()
{
	char a[3], b[3];
	while( scanf( "%s %s", a, b )!= EOF )
	{
		memset( map, 0, sizeof( map ) );
		map[ a[0]- 'a'+ 1 ][ a[1]- '0' ]= 1;
		map[ b[0]- 'a'+ 1 ][ b[1]- '0' ]= 2;
		printf( "To get from %s to %s takes %d knight moves.\n", a, b, BFS( a[0]- 'a'+ 1, a[1]- '0' ) );
	}
}

原文地址:https://www.cnblogs.com/Lyush/p/2132259.html