HDU1032 The 3n + 1 problem 不要打表

The 3n + 1 problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8771    Accepted Submission(s): 3203


Problem Description

Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

Consider the following algorithm:


    1.      input n

    2.      print n

    3.      if n = 1 then STOP

    4.           if n is odd then n <- 3n + 1

    5.           else n <- n / 2

    6.      GOTO 2


Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.
 

Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

You can assume that no opperation overflows a 32-bit integer.
 

Output

For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).
 

Sample Input
1 10
100 200
201 210
900 1000
 

Sample Output
1 10 20
100 200 125
201 210 89
900 1000 174
 
  暴力0MS, 打表G++ 600MS+ , C++ 800MS+    数据弱啊
  这时打表的代码:
#include <cstdio>
#include <iostream>
#include <cmath>

using namespace std;

int rec[1000005]; void swap( int &a, int &b ) { int temp= a; a= b; b= temp; } int main( ) { for( int i= 1; i<= 1000000; ++i ) { long long temp= i; // 有些数据会在处理过程中溢出int型 int cnt= 1; // 默认加上那个最后的那个1 while( temp!= 1 ) { if( !( temp& 1 ) ) { temp>>= 1; } else { temp= 3* temp+ 1; } cnt++; } rec[i]= cnt; } int l, r; while( scanf( "%d %d", &l, &r )!= EOF ) { int max= -1; int ll= l, rr= r; if( ll> rr ) { swap( ll, rr ); } for( int i= ll; i<= rr; ++i ) { if( max< rec[i] ) { max= rec[i]; } } printf( "%d %d %d\n", l, r, max ); } return 0; }

  暴力代码:

#include <cstdio>
#include <iostream>
#include <cmath>

using namespace std;

void swap( int &a, int &b )
{
	int temp= a;
	a= b;
	b= temp;
}

int get( long long x )
{
    int cnt= 1;
    while( x!= 1 )
    {
        if( x& 1 )
        {
            x= 3* x+ 1;
        }
        else
        {
            x>>= 1;
        }
        cnt++;
    }
    return cnt;
}

int main(  )
{
	int l, r;
	while( scanf( "%d %d", &l, &r )!= EOF )
	{
		int max= -1;
		int ll= l, rr= r;
		if( ll> rr )
		{
			swap( ll, rr );
		}
		for( int i= ll; i<= rr; ++i )
		{
			int temp= get( i );
			max= max> temp? max: temp;
		}
		printf( "%d %d %d\n", l, r, max );
	}
	return 0;
}

原文地址:https://www.cnblogs.com/Lyush/p/2122746.html