L1-064 估值一亿的AI核心代码 (20 分)

L1-064 估值一亿的AI核心代码 (20 分)


以上图片来自新浪微博。
本题要求你实现一个稍微更值钱一点的 (AI) 英文问答程序,规则是:

  • 无论用户说什么,首先把对方说的话在一行中原样打印出来;
  • 消除原文中多余空格:把相邻单词间的多个空格换成 (1) 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
  • 把原文中所有大写英文字母变成小写,除了 I
  • 把原文中所有独立的 can youcould you 对应地换成 I canI could—— 这里“独立”是指被空格或标点符号分隔开的单词;
  • 把原文中所有独立的 Ime 换成 you
  • 把原文中所有的问号 ? 换成惊叹号 !
  • 在一行中输出替换后的句子作为 (AI) 的回答。

输入格式:

输入首先在第一行给出不超过 (10) 的正整数 (N),随后 (N) 行,每行给出一句不超过 (1000) 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。

输出格式:

按题面要求输出,每个 (AI) 的回答前要加上 AI: 和一个空格。

输入样例:

6
Hello ?
 Good to chat   with you
can   you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don 't know

输出样例:

Hello ?
AI: hello!
 Good to chat   with you
AI: good to chat with you
can   you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don 't know
AI: what Is this prime! you,don't know

代码:

#include<bits/stdc++.h>
using namespace std;
int n,k;
char ch;
string s;
int main()
{
    cin>>n;
    while((ch=getchar())!='
')continue;
    while(n--)
    {
        getline(cin,s);
        cout<<s<<endl;
        cout<<"AI: ";
        for(int i=0;s[i]!='';i++)
        {
            if(!ispunct(s[i]))continue;
            s.insert(i," ");
            if(s[i+2]==' ')s.insert(i+2,"1");
            else s.insert(i+2,"0 ");
            i+=3;
        }
        s=' '+s+' ';
        for(int i=0;s[i]!='';i++)
        {
            if(s[i]=='I')continue;
            if(!isalpha(s[i]))continue;
            s[i]=tolower(s[i]);
        }

        while((k=s.find("  "))!=string::npos)s.replace(k,2," ");
        while((k=s.find(" ?0 "))!=string::npos)s.replace(k,4," !0 ");
        while((k=s.find(" ?1 "))!=string::npos)s.replace(k,4," !1 ");
        while((k=s.find(" could you "))!=string::npos)s.replace(k,11," I0 could ");
        while((k=s.find(" can you "))!=string::npos)s.replace(k,9," I0 can ");
        while((k=s.find(" I "))!=string::npos)s.replace(k,3," you ");
        while((k=s.find(" me "))!=string::npos)s.replace(k,4," you ");
        while((k=s.find(" I0 "))!=string::npos)s.replace(k,4," I ");
        for(int i=0;s[i]!='';i++)
        {
            if(!ispunct(s[i]))continue;
            if(s[i+1]=='1')s.erase(i+1,1);
            else s.erase(i+1,2);
            if(s[i-1]==' ')s.erase((i--)-1,1);
        }
        while(s[0]==' ')s.erase(0,1);
        while(s[s.length()-1]==' ')s.erase(s.length()-1,1);
        cout<<s<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/LengYun/p/14687710.html