Corporative Network

Corporative Network:

题目描述:

A very big corporation is developing its corporative network. In the beginning each of the N enterprises of the corporation, numerated from 1 to N, organized its own computing and telecommunication center. Soon, for amelioration of the services, the corporation started to collect some enterprises in clusters, each of them served by a single computing and telecommunication center as follow. The corporation chose one of the existing centers I (serving the cluster A) and one of the enterprises J in some other cluster B (not necessarily the center) and link them with telecommunication line. The length of the line between the enterprises I and J is |I – J|(mod 1000).In such a way the two old clusters are joined in a new cluster, served by the center of the old cluster B. Unfortunately after each join the sum of the lengths of the lines linking an enterprise to its serving center could be changed and the end users would like to know what is the new length. Write a program to keep trace of the changes in the organization of the network that is able in each moment to answer the questions of the users.

输入:

Your program has to be ready to solve more than one test case. The first line of the input will contains only the number T of the test cases. Each test will start with the number N of enterprises (5<=N<=20000). Then some number of lines (no more than 200000) will follow with one of the commands: E I – asking the length of the path from the enterprise I to its serving center in the moment; I I J – informing that the serving center I is linked to the enterprise J. The test case finishes with a line containing the word O. The I commands are less than N.

输出:

The output should contain as many lines as the number of E commands in all test cases with a single number each – the asked sum of length of lines connecting the corresponding enterprise with its serving center.

样例输入:

1
4
E 3
I 3 1
E 3
I 1 2
E 3
I 2 4
E 3
O

样例输出:

1
4
E 3
I 3 1
E 3
I 1 2
E 3
I 2 4
E 3
O

题解:

本题是一道带有边权的并查集问题,题目大意是,给出n个点,并给出一系列操作,其中E x操作表示查询x节点到根节点的距离,(ps.两个节点的距离为(left|x-y ight|mod 1000)),I x y 操作代表将x节点连接到y上,操作序列以O结尾(O不做任何操作)。根据题意可以看出我们只需要维护边权就可以,这题不同的是,他的合并是有要求的,必须是x接到y上,话不多说直接上代码:

/******************************************
/@Author: LeafBelief
/@Date: 2020-03-08
/@Remark:    
/@FileName: CorporativeNetwork
******************************************/
#include <bits/stdc++.h>
#define CSE(x, y) memset(x, y, sizeof(x))
#define lowbit(x) (x & (-x))
#define INF 0x3f3f3f3f
#define FAST ios::sync_with_stdio(false); cin.tie(0);
using namespace std;

typedef long long ll;
typedef pair<int, int> pii;
typedef pair<ll, ll> pll;

const int maxn = 22222;
int pre[maxn], dis[maxn];

int find(int x)
{
    if (x != pre[x])
    {
        int temp = pre[x];
        pre[x] = find(pre[x]);
        dis[x] += dis[temp];
    }
    return pre[x];
}

void merge(int x, int y)
{
    pre[x] = y;
    dis[x] = abs(x - y) % 1000;
    return;
}

int main()
{
#ifndef ONLINE_JUDGE
    freopen("in.in", "r", stdin);
#endif
    FAST;
    int t;
    cin >> t;
    while (t--)
    {
        CSE(pre, 0);
        CSE(dis, 0);
        int n;
        cin >> n;
        for (int i = 1; i <= n; i++)
        {
            pre[i] = i;
        }
        char d;
        while (cin >> d && d != 'O')
        {
            if (d == 'E')
            {
                int x;
                cin >> x;
                find(x);
                cout << dis[x] << endl;
            }
            else if (d == 'I')
            {
                int x, y;
                cin >> x >> y;
                pre[x] = y;
                dis[x] = abs(x - y) % 1000;
            }
        }
    }
    return 0;
}
原文地址:https://www.cnblogs.com/LeafLove/p/12447469.html