HD1013Digital Roots

Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.
For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output

For each integer in the input, output its digital root on a separate line of the output.

Sample Input

24 39 0

Sample Output

6 3

这题来自NewYork的题,其实一道数论题,有个小技巧,不过还是要用大数转换为字符串的方法,把每个数字相加,还是会很大.但这时可以用int了,接下来要用点数学知识:

/*
说明1.各位数字相加得到数x,这个x等于原来的数除以9的余数(原数为9的倍数除外)
    2.若原数为9的倍数,最后结果就是9;
   3.一个数字除以9的余数等于该数各数字之和除以9的余数。(这点为大数运算提供了极大的方便!)
*/

#include<iostream>
#include<string>
using namespace std;
int main(){
    int sum,i,x;
    char s[1010];
    while(cin>>s && s[0]!='0')
    {
        sum = 0;
        for(i=0;i<strlen(s);i++)
            sum +=s[i]-'0';
        x = sum % 9;
        if(x==0)  x=9;
        cout<<x<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/LZYY/p/3306535.html