[POJ 3345] Bribing FIPA

问题描述

There is going to be a voting at FIPA (Fédération Internationale de Programmation Association) to determine the host of the next IPWC (International Programming World Cup). Benjamin Bennett, the delegation of Diamondland to FIPA, is trying to seek other delegation's support for a vote in favor of hosting IWPC in Diamondland. Ben is trying to buy the votes by diamond gifts. He has figured out the voting price of each and every country. However, he knows that there is no need to diamond-bribe every country, since there are small poor countries that take vote orders from their respected superpowers. So, if you bribe a country, you have gained the vote of any other country under its domination (both directly and via other countries domination). For example, if C is under domination of B, and B is under domination of A, one may get the vote of all three countries just by bribing A. Note that no country is under domination of more than one country, and the domination relationship makes no cycle. You are to help him, against a big diamond, by writing a program to find out the minimum number of diamonds needed such that at least m countries vote in favor of Diamondland. Since Diamondland is a candidate, it stands out of the voting process.

输入格式

The input consists of multiple test cases. Each test case starts with a line containing two integers n (1 ≤ n≤ 200) and m (0 ≤ mn) which are the number of countries participating in the voting process, and the number of votes Diamondland needs. The next n lines, each describing one country, are of the following form:

CountryName DiamondCount DCName1 DCName1 ...

CountryName, the name of the country, is a string of at least one and at most 100 letters and DiamondCount is a positive integer which is the number of diamonds needed to get the vote of that country and all of the countries that their names come in the list DCName1 DCName1 ... which means they are under direct domination of that country. Note that it is possible that some countries do not have any other country under domination. The end of the input is marked by a single line containing a single # character.

输出格式

For each test case, write a single line containing a number showing the minimum number of diamonds needed to gain the vote of at least m countries.

样例输入

3 2
Aland 10
Boland 20 Aland
Coland 15

样例输出

20

题目大意

有一棵n个节点的树,给一个节点染色的话,该节点的子树的所有节点都会被染色。而给每一个节点染色都有一个代价,要求用最少的代价使被染色的节点数量不少于m。

解析

最直接的想法是设(f[i][k])表示有i个节点被染色时的最小代价。同时设(size[i])表示以(i)为根的子树大小,那么容易得到以下状态转移方程:

[f[i][k]=min(f[i-size[j]][k]+w[i])_{jin i} ]

但在实现时还有些细节需要注意。为了节约空间,可以在每一层递归中开一个数组记录当前的(f)的值,这样就可以节约掉(f)的第二维。

这道题的毒瘤输入也值得一提......

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <map>
#define N 402
using namespace std;
int head[N],ver[N*2],nxt[N*2],l;
int f[N],w[N],din[N],size[N],n,m,i,cnt,ans=0;
char s[102];
string u,v;
map<string,int> d;
void insert(int x,int y)
{
	l++;
	din[y]++;
	ver[l]=y;
	nxt[l]=head[x];
	head[x]=l;
}
void init(int x,int pre)
{
	size[x]=1;
	for(int i=head[x];i;i=nxt[i]){
		int y=ver[i];
		if(y!=pre){
			init(y,x);
			size[x]+=size[y];
		}
	}
}
void dp(int x,int y)
{
	int tmp[N]={0};
	for(int i=0;i<=n;i++) tmp[i]=f[i];
	for(int i=head[x];i;i=nxt[i]){
		int y=ver[i];
	    dp(y,x);
	}
	for(int i=n;i>=size[x];i--){
		tmp[i]=min(tmp[i],tmp[i-size[x]]+w[x]);
		f[i]=min(f[i],tmp[i]);
	}
}
int main()
{
	while(gets(s)){
		if(s[0]=='#') break;
		sscanf(s,"%d%d",&n,&m);
		memset(f,0x3f,sizeof(f));
	    memset(head,0,sizeof(head));
		memset(din,0,sizeof(din));
		d.clear();
		f[0]=l=cnt=0;
		for(i=1;i<=n;i++){
			int p;
			cin>>u>>p;
			if(d[u]==0) d[u]=++cnt;
			w[d[u]]=p;
			char c=getchar();
			while(c==' '){
				cin>>v;
				if(d[v]==0) d[v]=++cnt;
				insert(d[u],d[v]);
				c=getchar();
			}
		}
		for(i=1;i<=n;i++){
			if(din[i]==0) init(i,0);
		}
		for(i=1;i<=n;i++){
			if(din[i]==0) dp(i,0);
		}
		ans=1<<30;
		for(i=m;i<=n;i++) ans=min(ans,f[i]);
		cout<<ans<<endl;
	}
	return 0;
}
原文地址:https://www.cnblogs.com/LSlzf/p/10973537.html