[CH5E02] A Little Shop of Flowers

问题描述

You want to arrange the window of your flower shop in a most pleasant way. You have F bunches of flowers, each being of a different kind, and at least as many vases ordered in a row. The vases are glued onto the shelf and are numbered consecutively 1 through V, where V is the number of vases, from left to right so that the vase 1 is the leftmost, and the vase V is the rightmost vase. The bunches are moveable and are uniquely identified by integers between 1 and F. These id-numbers have a significance: They determine the required order of appearance of the flower bunches in the row of vases so that the bunch i must be in a vase to the left of the vase containing bunch j whenever i < j. Suppose, for example, you have bunch of azaleas (id-number=1), a bunch of begonias (id-number=2) and a bunch of carnations (id-number=3). Now, all the bunches must be put into the vases keeping their id-numbers in order. The bunch of azaleas must be in a vase to the left of begonias, and the bunch of begonias must be in a vase to the left of carnations. If there are more vases than bunches of flowers then the excess will be left empty. A vase can hold only one bunch of flowers.

Each vase has a distinct characteristic (just like flowers do). Hence, putting a bunch of flowers in a vase results in a certain aesthetic value, expressed by an integer. The aesthetic values are presented in a table as shown below. Leaving a vase empty has an aesthetic value of 0.

V A S E S
1 2 3 4 5
Bunches 1 (azaleas) 7 23 -5 -24 16
2 (begonias) 5 21 -4 10 23
3 (carnations) -21 5 -4 -20 20

According to the table, azaleas, for example, would look great in vase 2, but they would look awful in vase 4.

To achieve the most pleasant effect you have to maximize the sum of aesthetic values for the arrangement while keeping the required ordering of the flowers. If more than one arrangement has the maximal sum value, any one of them will be acceptable. You have to produce exactly one arrangement.

输入格式

  • The first line contains two numbers: F, V.

  • The following F lines: Each of these lines contains V integers, so that Aij is given as the jth number on the (i+1)st line of the input file.

  • 1 <= F <= 100 where F is the number of the bunches of flowers. The bunches are numbered 1 through F.

  • F <= V <= 100 where V is the number of vases.

  • -50 <= Aij <= 50 where Aij is the aesthetic value obtained by putting the flower bunch i into the vase j.

输出格式

The first line will contain the sum of aesthetic values for your arrangement.

样例输入

3 5
7 23 -5 -24 16
5 21 -4 10 23
-21 5 -4 -20 20

样例输出

53

题目大意

给你一些花和一些花瓶,其中花要放在花瓶里,花和花瓶的摆放必须按照编号顺序,即序号小的不能放在序号大的右边。每个花放在不同的花瓶中都有不同的贡献,求最大的贡献总和。

解析

一道比较水的线性动态规划。既然都只能按照顺序来摆放,那么每一个状态都只与它前面的状态有关。设f[i][j]表示前i朵花放在前j个花瓶里的最大贡献。那么我们可以用前面的摆放方式推出f[i][j]。设当前花为i,摆在前j个花瓶中,k为小于j的花瓶编号,那么有状态转移方程如下:

[f[i][j]=max(f[i][j],f[i-1][k]+a[i][j]) ]

其中a[i][j]表示第i朵花放在第j个花瓶中的贡献。最后答案即为f[n][m]。

注意,(1)由于可能出现负数,f数组初始化时要设成负无穷大,边界状态还是设为0。(2)每次决定花瓶时要保证最后剩下的花瓶能够摆下剩下的花,前面的花瓶能够摆下前面已经摆过的花。

代码

#include <iostream>
#include <cstdio>
#define N 102
using namespace std;
int n,m,i,j,k,a[N][N],f[N][N];
int main()
{
	cin>>n>>m;
	for(i=1;i<=n;i++){
		for(j=1;j<=m;j++) cin>>a[i][j];
	}
    for(i=1;i<=n;i++){
		for(j=1;j<=m;j++) f[i][j]=-(1<<30);
	}
	for(i=1;i<=m;i++) f[0][i]=0;
	for(i=1;i<=n;i++){
		for(j=i;j<=m-(n-i);j++){
			for(k=i-1;k<j;k++){
				f[i][j]=max(f[i][j],f[i-1][k]+a[i][j]);
			}
		}
	}
    cout<<f[n][m]<<endl;
	return 0;
}
原文地址:https://www.cnblogs.com/LSlzf/p/10636961.html