2016HUAS暑假集训训练2 A

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
解析:

本题本是一道并查集的题,但出的数据比较小,因此用树的特点即一个点入度为0其他的全为1且边的条数等于顶点数减一即可下面是我的AC代码:

#include<iostream>
#include <cstring>
using namespace std;
int main()
{

    int n = 0, x, y, fff, i, j,sss[15], t = 0, k = 0, s ,ss, f, ff = 0, a[10005], b[10005], r[10005];

    while (cin >> x >> y)
    {
        if (x <0 || y <0) break;
        ff ++;
        if (x == 0 && y == 0 && t == 0 && k == 0)//空数也是数   易忽略
        {
            cout << "Case " << ++n << " is a tree." << endl;
            t = 0; k = 0; ff = 0;

            continue;
        }
        a[t++] = y;  //保存入度的点
        b[k++] = x; b[k++] = y; // 保存所有的点
        if (x == 0 && y == 0 && (t != 0 && k != 0))
        {
             ss = 0;
             memset(sss,0,sizeof(sss));
            for (i = 0 ; i < k - 1; i ++)
                 sss[b[i]] ++;
                 for(i = 0; i <= 15; i ++)//找到顶点数
                 if(sss[i] > 0) ss ++;
            f = 1; s = 0;
            for (i = 0; i < t - 1; i ++) //判断是否入度是否有大于2的和找到入度为一的个数
            {
                for (j = i + 1; j < t; j ++)
                {
                    if (a[i] == a[j])
                    {
                        f = 0; break;
                    }
                }
                s++;
            }
            
            if (f == 1 && ss - s == 2 && ss - ff == 1&&ff - s == 1)//根据定义判断是否是树
                cout << "Case " << ++n << " is a tree." << endl;
            else
                cout << "Case " << ++n << " is not a tree." << endl;

                 t = 0; k = 0; ff = 0;
        }

    }
    return 0;
}

  

原文地址:https://www.cnblogs.com/LIUWEI123/p/5697161.html