POJ1144 Network(割点)题解

Description

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is 
possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure 
occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated 
by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;

Output

The output contains for each block except the last in the input file one line containing the number of critical places.

Sample Input

5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0

Sample Output

1
2


思路:

求割点模板题,再输入那里WA了两发orz...,以为最多只能n行就加了个while。

因为是个无向图,所以tarjan(1)就行了,根节点也就只有1了

判断割点的方法:

1.是根节点:如果son>=2就是割点

2.不是根节点:如果low[v]>=dfn[x]那么x就是割点

代码:

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cctype>
#include<queue>
#include<cmath>
#include<string>
#include<map>
#include<stack> 
#include<set>
#include<vector>
#include<iostream>
#include<algorithm>
#include<sstream>
#define ll long long 
const int N=110;
const int INF=1e9;
using namespace std;
int cnt;
int dfn[N],low[N];
vector<int> g[N];
map<int,int> ans;

void tarjan(int x){
	dfn[x]=low[x]=cnt++;
	int son=0;
	for(int i=0;i<g[x].size();i++){
		int v=g[x][i];
		if(!dfn[v]){
			son++;
			tarjan(v);
			low[x]=min(low[x],low[v]);
			if(low[v]>=dfn[x] && dfn[x]!=1) ans[x]++;
			else if(x==1 && son>1){
				ans[x]++;
			}
		}
		else{
			low[x]=min(low[x],dfn[v]);

		}
	}
	
} 
void init(){
	cnt=1;
	for(int i=0;i<N;i++) g[i].clear();
	ans.clear();
	memset(dfn,0,sizeof(dfn));
	memset(low,0,sizeof(low));
}
int main(){
    int n,a,b;
    string s;
	while(~scanf("%d",&n) && n){
		init();
		getchar();
		while(true){
			getline(cin,s);
			stringstream ss(s);
			ss>>a;
			if(!a) break;
			while(ss>>b && b){
				g[a].push_back(b);
				g[b].push_back(a);
			}
		}
		tarjan(1);
		cout<<ans.size()<<endl;
	} 
    return 0;
}


原文地址:https://www.cnblogs.com/KirinSB/p/9409106.html