HDU 1285 确定比赛名次(拓扑排序)题解

Problem Description
有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。
 

Input
输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。
 

Output
给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。

其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。
 

Sample Input
4 31 22 34 3
 
Sample Output
1 2 4 3

思路:

拓扑排序,这里用来解决A<B,A<C,B<C   =》   A<B<C这样的排序问题。

过程就是:先用优先队列压入入度为0的点,我们抹去这个点,然后删除从该点出发的边,同时减小终点的入度,当终点入度也为0时压入优先队列,重复操作,直到所有点入度为0。

代码:

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cctype>
#include<queue>
#include<cmath>
#include<string>
#include<stack> 
#include<set>
#include<vector>
#include<iostream>
#include<algorithm>
#include<sstream>
#define ll long long 
const int N=510;
const int INF=1e9;
using namespace std;
int n,map[N][N],indegree[N];	//map[i][j]表示i赢了[j],入度 

void topo(){
	priority_queue<int,vector<int>,greater<int> > q; 	//最后有一个空格  greater升序,less降序
	for(int i=1;i<=n;i++){
		if(!indegree[i]){
			q.push(i);
		}
	}
	int flag=1,top;
	while(!q.empty()){
		top=q.top();
		q.pop();
		indegree[top]=-1;
		if(flag){
			printf("%d",top);
			flag=0;
		}
		else{
			printf(" %d",top);
		}
		for(int i=1;i<=n;i++){
			if(map[top][i]){
				indegree[i]--;
				if(!indegree[i]){
					q.push(i);
				}
			}
		}
	}
	cout<<endl;
}

int main(){
	int m,a,b;
	while(~scanf("%d%d",&n,&m)){
		memset(map,0,sizeof(map));
		memset(indegree,0,sizeof(indegree));
		for(int i=0;i<m;i++){
			scanf("%d%d",&a,&b);
			if(map[a][b]==0){
				map[a][b]=1;
				indegree[b]++;
			}
		}
		topo();
	}	
    return 0;  
}  


原文地址:https://www.cnblogs.com/KirinSB/p/9409103.html