BZOJ3829[Poi2014]FarmCraft——树形DP+贪心

题目描述

In a village called Byteville, there are   houses connected with N-1 roads. For each pair of houses, there is a unique way to get from one to another. The houses are numbered from 1 to  . The house no. 1 belongs to the village administrator Byteasar. As part of enabling modern technologies for rural areas framework,   computers have been delivered to Byteasar's house. Every house is to be supplied with a computer, and it is Byteasar's task to distribute them. The citizens of Byteville have already agreed to play the most recent version of FarmCraft (the game) as soon as they have their computers.
Byteasar has loaded all the computers on his pickup truck and is about to set out to deliver the goods. He has just the right amount of gasoline to drive each road twice. In each house, Byteasar leaves one computer, and immediately continues on his route. In each house, as soon as house dwellers get their computer, they turn it on and install FarmCraft. The time it takes to install and set up the game very much depends on one's tech savviness, which is fortunately known for each household. After he delivers all the computers, Byteasar will come back to his house and install the game on his computer. The travel time along each road linking two houses is exactly 1 minute, and (due to citizens' eagerness to play) the time to unload a computer is negligible.
Help Byteasar in determining a delivery order that allows all Byteville's citizens (including Byteasar) to start playing together as soon as possible. In other words, find an order that minimizes the time when everyone has FarmCraft installed.
mhy住在一棵有n个点的树的1号结点上,每个结点上都有一个妹子。
mhy从自己家出发,去给每一个妹子都送一台电脑,每个妹子拿到电脑后就会开始安装zhx牌杀毒软件,第i个妹子安装时间为Ci。
树上的每条边mhy能且仅能走两次,每次耗费1单位时间。mhy送完所有电脑后会回自己家里然后开始装zhx牌杀毒软件。
卸货和装电脑是不需要时间的。
求所有妹子和mhy都装好zhx牌杀毒软件的最短时间。

输入

The first line of the standard input contains a single integer N(2<=N<=5 00 000)  that gives the number of houses in Byteville. The second line contains N integers C1,C2…Cn(1<=Ci<=10^9), separated by single spaces; Ci is the installation time (in minutes) for the dwellers of house no. i.
The next N-1  lines specify the roads linking the houses. Each such line contains two positive integers a and b(1<=a<b<=N) , separated by a single space. These indicate that there is a direct road between the houses no. a and b.

输出

The first and only line of the standard output should contain a single integer: the (minimum) number of minutes after which all citizens will be able to play FarmCraft together.

样例输入

6
1 8 9 6 3 2
1 3
2 3
3 4
4 5
4 6

样例输出

11

提示

Explanation: Byteasar should deliver the computers to the houses in the following order: 3, 2, 4, 5, 6, and 1. The game will be installed after 11, 10, 10, 10, 8, and 9 minutes respectively, in the house number order. Thus everyone can play after 11 minutes.
If Byteasar delivered the game in the following order: 3, 4, 5, 6, 2, and 1, then the game would be installed after: 11, 16, 10, 8, 6, and 7 minutes respectively. Hence, everyone could play only after 16 minutes,
 
首先能想到一定是按什么顺序来遍历子树的,遍历一棵子树一定要遍历完才遍历其他子树,那么按什么顺序遍历呢?
不妨设f[i]表示以i为根节点的子树中最长耗时是多少(是指从i开始走的最长耗时)。
对于一个点i的两个子节点a,b(其中size[]代表子树大小):
如果先遍历a再遍历b,则a的耗时是1+f[a],b的耗时是1+2*size[a]+f[b]
如果先遍历b再遍历a,则a的耗时是1+2*size[b]+f[a],b的耗时是1+f[b]
f[i]=min(max(f[a],2*size[a]+f[b]),max(f[b],2*size[b]+f[a]))
到这一步就可以按上式排序遍历了,但还可以再进一步简化。
我们分类讨论上式两个最大值分别是什么:
1、f[a]>2*size[a]+f[b];f[b]>2*size[b]+f[a],这种情况显然是不可能的
2、f[a]>2*size[a]+f[b];2*size[b]+f[a]>f[b],显然2*size[b]+f[a]>f[a]>2*size[a]+f[b],这种情况优先遍历a更优
即2*size[b]+f[a]>2*size[a]+f[b],f[a]-2*size[a]>f[b]-2*size[b],也就是优先遍历f[]-2*size[]大的
3、2*size[a]+f[b]>f[a];f[b]>2*size[b]+f[a],显然2*size[a]+f[b]>f[b]>2*size[b]+f[a],这种情况优先遍历b更优
即2*size[a]+f[b]>2*size[b]+f[a],f[b]-2*size[b]>f[a]-2*size[a],同样是优先遍历f[]-2*size[]大的
4、2*size[a]+f[b]>f[a];2*size[b]+f[a]>f[b],假设遍历a更优,反过来同样
即2*size[a]+f[b]<2*size[b]+f[a],f[b]-2*size[b]<f[a]-2*size[a],依然是优先遍历f[]-2*size[]大的
那么只要按f[]-2*size[]排序之后更新f[i]就好了。
因为1号节点要求回来再安装,因此将f[1]初始成0,最后再比较一下f[1]和2*size[1]-2+c[1]的大小即可。
#include<set>
#include<map>
#include<queue>
#include<stack>
#include<cmath>
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define ll long long
using namespace std;
int c[500010];
int n;
int head[500010];
int to[1000010];
int next[1000010];
int size[500010];
int fa[500010];
ll f[500010];
int q[500010];
int x,y;
int tot;
void add(int x,int y)
{
    tot++;
    next[tot]=head[x];
    head[x]=tot;
    to[tot]=y;
}
bool cmp(int x,int y)
{
    return f[x]-2*size[x]>f[y]-2*size[y];
}
void dfs(int x)
{
    int cnt=0;
    int sum=1;
    size[x]=1;
    f[x]=c[x];
    if(x==1)
    {
        f[x]=0;
    }
    for(int i=head[x];i;i=next[i])
    {
        if(to[i]!=fa[x])
        {
            fa[to[i]]=x;
            dfs(to[i]);
            size[x]+=size[to[i]];
        }
    }
    for(int i=head[x];i;i=next[i])
    {
        if(to[i]!=fa[x])
        {
            q[++cnt]=to[i];
        }
    }
    sort(q+1,q+1+cnt,cmp);
    for(int i=1;i<=cnt;i++)
    {
        f[x]=max(f[x],f[q[i]]+sum);
        sum+=2*size[q[i]];
    }
}
int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&c[i]);
    }
    for(int i=1;i<n;i++)
    {
        scanf("%d%d",&x,&y);
        add(x,y);
        add(y,x);
    }
    dfs(1);
    printf("%lld",max(2ll*(n-1)+c[1],f[1]));
}
原文地址:https://www.cnblogs.com/Khada-Jhin/p/9637326.html