BZOJ2277[Poi2011]Strongbox——数论

题目描述

Byteasar is a famous safe-cracker, who renounced his criminal activity and got into testing and certifying anti-burglary devices. He has just received a new kind of strongbox for tests: a combinatorial safe. A combinatorial safe is something different from a combination safe, even though it is opened with a rotary dial. The dial can be set in different positions, numbered from 0 to n-1. Setting the dial in some of these positions opens the safe, while in others it does not. And here is the combinatorial property, from which the name comes from: if x and y are opening positions, then so is (x+y) mod n too; note that is holds for x=y as well.
Byteasar tried k different positions of the dial: m1,m2….mk. The positions M1,M 2….Mk-1 did not open the safe, only the last position Mk did. Byteasar is already tired from checking these K positions and has thus absolutely no intention of trying the remaining ones. He would like to know however, based on what he already knows about the positions he tried, what is the maximum possible number of positions that open the safe. Help him by writing an appropriate program!

有一个密码箱,0到n-1中的某些整数是它的密码。
且满足,如果a和b都是它的密码,那么(a+b)%n也是它的密码(a,b可以相等)
某人试了k次密码,前k-1次都失败了,最后一次成功了。
问:该密码箱最多有多少不同的密码。

输入

The first line of the standard input gives two integers N and k, separated by a single space, (1<=K<=250000,k<=N<=10^14), The second line holds K different integers, also separated by single spaces, m1,m2….mk, 0<=Mi<N. You can assume that the input data correspond to a certain combinatorial safe that complies with the description above.
In tests worth approximately 70% of the points it holds that k<=1000. In some of those tests, worth approximately 20% of the points, the following conditions hold in addition: N< 10 ^8 and K<=100.

第一行n,k
下面一行k个整数,表示每次试的密码
保证存在合法解

1<=k<=250000 k<=n<=10^14

输出

Your program should print out to the first and only line of the standard output a single integer: the maximum number of the dial's positions that can open the safe.

一行,表示结果

样例输入

42 5
28 31 10 38 24

样例输出

14
 
  如果x,y是密码,那么gcd(x,y)的倍数就都是密码(证明在最后)。同理,如果x是密码,那么2x,3x,4x……kx都是密码,那么gcd(x,n)的倍数就都是密码,反之则一定不是。因为前k-1次都没试出来,所以gcd(a[i],n)(i<k)就都不是密码,假设x是密码,那么x一定不是gcd(a[i],n)的约数,又因为gcd(a[k],n)是密码,所以x一定是gcd(a[k],n)的约数,枚举gcd(a[k],n)的约数验证,取n/x最大的就好了。为什么两个数i,j都满足但答案不能是n/i+n/j?因为如果i,j互质,那么gcd(i,j)=1,这样所有n内的数就都是密码了,显然不行。如果i,j不互质,那么gcd(i,j)的答案在前面已经被计算过了,n/i+n/j会重复。
证明:
设d=gcd(x,y),x=a*d,y=b*d,因为px+qy一定是密码(p,q>0),所以d*(ap+bq)就一定是密码。而gcd(x,y)的任意倍数是d*(ap'+bq')其中p',q'不一定是正数,那么只要保证(ap'+bq')在%n意义下且在p',q'>0时能表示所有正数就好了。因为a,b互质,所以ap'+bq'=1一定有解,但其中有一个一定是负数,只要把那个数一直+n直到为正就好了。加一个数的n倍%n结果不变。再把上述二元一次方程左右两边扩大任意倍数,就能表示d的任意倍了。
#include<map>
#include<set>
#include<queue>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int k;
int flag;
long long ans;
long long n;
long long a[250010];
long long gcd(long long x,long long y)
{
    if(y==0)
    {
        return x;
    }
    return gcd(y,x%y);
}    
int cnt=0;
bool check(long long x)
{
    for(int i=1;i<=cnt;i++)
    {
        if(a[i]%x==0)
        {
            return false;
        }
    }
    return true;
}
int main()
{
    long long y;
    scanf("%lld%d",&n,&k);
    for(int i=1;i<=k;i++)
    {
        scanf("%lld",&a[i]);
        a[i]=gcd(a[i],n);
    }
    long long x=a[k];
    ans=n;
    sort(a+1,a+k);
    for(int i=1;i<k;i++)
    {
        if(a[i]!=a[i-1])
        {
            a[++cnt]=a[i];
        }
    }
    for(long long i=1;i*i<=x;i++)
    {
        if(x%i==0)
        {
            if(check(i))
            {
                ans=n/i;
                break;
            }
            else if(check(a[k]/i))
            {
                ans=n/a[k]*i;
            }
        }
    }
    printf("%lld",ans);
}
原文地址:https://www.cnblogs.com/Khada-Jhin/p/9590059.html