ACM: Calculate a + b

链接网站:http://acm.zjut.edu.cn/(F(sjjtWtH02bLVHyNslt5NKayi1Agu4bdzxMKfSTGyIo8gb8qls2-vwcbxwSM24NX1Rodj2i5ju0a-foYfpCbGs3nmEOmZolw-T_BIg1eYiVO851VucMUUbc_qkB7ZkdpV2gtSu6On6HL0zSB7EJF0iqw0RaCIJU14D46bB3t5NFMMfkgA0))/ProblemList.aspx

Description:

Calculate a + b

Input:

The input will be consist of a series of pairs of integers a and b,separated by a space, one pair of integers per line, 0 0 means the end of the input, and do not need to output.    

Output:

For each pair of input integers a and b you should output the sum of a and b in one line,and with one line of output for each line in input.   

Sample Input:

1 5
0 0

Sample Output:

6


参考代码:
#include<iostream>
#include<string>
using namespace std;
void main()
{
    int a,b;
    int sum;
    string result;
    char s[100];
    while(cin>>a>>b)
    {
        if(a == 0 && b == 0)
            break;
        sum = a+b;
        sprintf(s, "%d",sum);//将整数转为字符串型
        result += s;
        result += "\n";
    }
    cout<<result;
}

截图:





原文地址:https://www.cnblogs.com/KeenLeung/p/2949112.html