PAT (Basic Level) Practice 1044 火星数字 (20分)

1.题目

火星人是以 13 进制计数的:

  • 地球人的 0 被火星人称为 tret。
  • 地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
  • 火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。

例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:

输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:

对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:

4
29
5
elo nov
tam

输出样例:

hel mar
may
115
13

2.题目分析

13的倍数只输出高位数,后面没有0

3.代码

#include<iostream>
#include<string>
#include<cstring>
#include<sstream>
using namespace std;
string a[13] = { "tret","jan", "feb","mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec" };
string b[13] = { "","tam", "hel","maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou" };
bool isnum(string str)
{
	for (int i = 0; i < str.length(); i++)
		if (!isdigit(str[i]))return false;
	return true;
}
int change(string str)
{
	int number;
	stringstream ss;
	ss << str;
	ss >> number;
	return number;
}

int main()
{
	int n;
	cin >> n;
	string temp;
	int aa=0, bb=0;
	getchar();
	for (int i = 0; i < n; i++)
	{
		getline(cin, temp);
		if (isnum(temp)) 
		{
			aa = change(temp)/13;
			bb = change(temp) % 13;
            if (change(temp) == 0)cout << "tret";
			if (aa != 0)cout << b[aa];
			if (bb != 0) {if(aa!=0) cout << ' ' << a[bb] << endl;else cout<< a[bb] << endl;}
			else cout << endl;
		}
		else
		{
			if (temp.find(' ') != string::npos)
			{
				string temp2 = temp.substr(temp.find(' ') + 1, temp.length() - 1);
				temp = temp.substr(0, temp.find(' '));
				for (int j = 0; j < 13; j++)
					 if (temp == b[j]) { aa=j * 13; break; }
				for (int j = 0; j < 13; j++)
					if (temp2 == a[j]) { aa =aa+ j; break; }
				cout << aa << endl;
			}
			else
			{
				for (int j = 0; j < 13; j++)
				{
					if (temp == a[j]) { cout << j << endl; break; }
					else if (temp == b[j]) { cout << j * 13 << endl; break; }
				}
			}
			
		}
	}

}
原文地址:https://www.cnblogs.com/Jason66661010/p/12788946.html