HDU 2899 Strange fuction 二分

Strange fuction
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Now, here is a fuction: 
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100) 
Can you find the minimum value when x is between 0 and 100.
 

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output

Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input

2 100 200
 

Sample Output

-74.4291
-178.8534
 
二分水题
 
 
#include <iostream>
#include <cstdio>
#include <math.h>
#include <cstring>
#include <algorithm>
#include <iomanip>

using namespace std;

double y;

double fx1(double x)
{
    return 42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x-y;
}


//F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
double fx(double x)
{
    return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-y*x;
}


int main()
{
    //freopen("input.txt","r",stdin);
    int t;
    cin>>t;
    while(t--)
    {
        cin>>y;
        double l=0;
        double r=100;
        double mid;
        while(r-l>1e-8)
        {
            mid=(l+r)/2;
            if(fx1(mid)>0)
            {
                r=mid;
            }
            else
            {
                l=mid;
            }
        }
        cout<<fixed<<setprecision(4)<<fx(r)<<endl;
    }
}

  

 
 
 
 
 
 
 
 
 
原文地址:https://www.cnblogs.com/Hyouka/p/5709411.html