POJ 3125 Printer Queue【暴力模拟】

Description

The only printer in the computer science students' union is experiencing an extremely heavy workload. Sometimes there are a hundred jobs in the printer queue and you may have to wait for hours to get a single page of output. 

Because some jobs are more important than others, the Hacker General has invented and implemented a simple priority system for the print job queue. Now, each job is assigned a priority between 1 and 9 (with 9 being the highest priority, 
and 1 being the lowest), and the printer operates as follows.
  • The first job J in queue is taken from the queue.
  • If there is some job in the queue with a higher priority than job J, thenmove J to the end of the queue without printing it.
  • Otherwise, print job J (and do not put it back in the queue).
In this way, all those importantmuffin recipes that the Hacker General is printing get printed very quickly. Of course, those annoying term papers that others are printing may have to wait for quite some time to get printed, but that's life. 

Your problem with the new policy is that it has become quite tricky to determine when your print job will actually be completed. You decide to write a program to figure this out. The program will be given the current queue (as a list of priorities) as well as the position of your job in the queue, and must then calculate how long it will take until your job is printed, assuming that no additional jobs will be added to the queue. To simplifymatters, we assume that printing a job always takes exactly one minute, and that adding and removing jobs from the queue is instantaneous.

Input

One line with a positive integer: the number of test cases (at most 100). Then for each test case:
  • One line with two integers n and m, where n is the number of jobs in the queue (1 ≤ n ≤ 100) and m is the position of your job (0 ≤ m ≤ n −1). The first position in the queue is number 0, the second is number 1, and so on.
  • One linewith n integers in the range 1 to 9, giving the priorities of the jobs in the queue. The first integer gives the priority of the first job, the second integer the priority of the second job, and so on.

Output

For each test case, print one line with a single integer; the number of minutes until your job is completely printed, assuming that no additional print jobs will arrive.

Sample Input

3
1 0
5
4 2
1 2 3 4
6 0
1 1 9 1 1 1

Sample Output

1
2
5

题目大意:给出一串打印的优先级,如果打印i点但是后面有比他优先级高的,那么就将他放到后面,打印优先级高于他的。
思路:用队列模拟,如果后面有优先级高于他的则放到后面,那么怎样判断后面是否有高于他的优先级的呢,将优先级放到数组a[]中排序按照从大到小,如果相等与a[top]那么就是打印的,并且它是你在的位置,break;如果相等与a[top]那么就是打印的但是位置不是他站的位置top++;如果小于a[top]则放入队尾;
代码如下:
View Code
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm> 
#include<queue> 
using namespace std; 
struct point
{
    int pla, num;
}; 
int cmp(int x, int y)
{
    return x>y;
} 
int main()
{
    int T, i, n, m;
    scanf("%d", &T);
    while(T--)
    {
        point p[105];
        int a[105]; 
        queue<point>Q; 
        scanf("%d%d", &n, &m);
        for(i=0; i<n; i++)
        {
            scanf("%d", &a[i]);
            p[i].num=a[i], p[i].pla=i;
            Q.push(p[i]); 
        }
        sort(a, a+n, cmp); 
        int maxtop=0; 
        int num=1; 
        while(1)
        {
             point x=Q.front();
             Q.pop();
            if(x.num==a[maxtop]&&x.pla!=m)
                maxtop++, num++; 
            else if(x.num==a[maxtop]&&x.pla==m)
                break;
            else
                Q.push(x);
        }
        printf("%d\n", num);
    }
    return 0; 
}     
原文地址:https://www.cnblogs.com/Hilda/p/2636881.html