POJ 1050 To the Max【最大子矩阵】

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

思路

将一维的求最大子序列的和进行加强版,同样这里采取相对暴力的方法,时间复杂度为O(N^3)的方法进行枚举每个子矩阵。

源码

#include<stdio.h>

#include<string.h>

#define MIN -99999999

int main()

{

       int i, j, k, f[101][101], a[101], n, mem[101];

       while(scanf("%d", &n)!=EOF)

       {

              for(i=1; i<=n; i++)

                     for(j=1; j<=n; j++)

                            scanf("%d", &f[i][j]);

              int maxnum=MIN, change;

              memset(a, 0, sizeof(a));

              for(i=1; i<=n; i++)

              {

                     memset(mem, 0, sizeof(mem));

                     for(j=i; j<=n; j++)

                     {

                            for(k=1; k<=n; k++)

                            {

                                   mem[k]+=f[j][k];

                                   a[k]=mem[k];

                            }

                            change=a[1];

                            for(k=2; k<=n; k++)

                            {

                                   a[k]=a[k]>a[k]+a[k-1]?a[k]:a[k]+a[k-1];

                                   change=a[k]>change?a[k]:change;

                            }

                            maxnum=maxnum>change?maxnum:change;

                     }

              }

              printf("%d\n", maxnum);

       }

}

原文地址:https://www.cnblogs.com/Hilda/p/2617235.html