HDU 1003 Max Sum【最大连续子序列的和】

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
 
Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

思路

状态转移方程是:sum[i]=sum[i-1]>0?:sum[i-1]+a[i]:a[i]

源码

#include<stdio.h>

#define min -99999999

int main ()

{

    int i, n, m, sum, end, start, j, son, b, maxsum;

    scanf("%d", &n) ;

    for(i=1; i<=n; i++ ) 

    {

        scanf("%d", &m ) ;

        start=0;

        end=0 ;

        maxsum=min ;

        sum=0 ;

        b=1 ;

        for(j=1; j<=m; j++ ) 

        {

            scanf("%d", &son) ;

            sum+=son ;

            if(sum>maxsum) 

            {

                 maxsum=sum ;

                 start=b;

                 end=j ;

            }

                     if(sum<0) 

                     {

                            sum = 0;

                            b = j+1 ;

                     }

              }

        printf( "Case %d:\n", i) ;

        printf( "%d %d %d\n", maxsum, start, end);

        if(i!=n) 

                     printf("\n") ;

    }

}

原文地址:https://www.cnblogs.com/Hilda/p/2617233.html