POJ 3624 Charm Bracelet【01背包】

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

思路

简单01背包进行套用模板即可:

for i=1…..N

  for v=V….0

      f[v]=max(f[v], f[v-c[i]]+w[i];

源码

#include<stdio.h>

#include<string.h>

#include<iostream>

using namespace std;

int main()

{

       int w[3500], d[3500], m, n, i, bag[15000], j;

       while(scanf("%d%d", &n, &m)!=EOF)

       {

              memset(bag, 0, sizeof(bag));

              for(i=1; i<=n; i++)

                     scanf("%d%d", &w[i], &d[i]);

              for(i=1; i<=n; i++)

                     for(j=m; j>=w[i]; j--)

                     {

                                   bag[j]=max(bag[j], bag[j-w[i]]+d[i]);

                     }

              printf("%d\n", bag[m]);

       }

}

原文地址:https://www.cnblogs.com/Hilda/p/2616900.html