POJ:3268-Silver Cow Party

Silver Cow Party

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 26184 Accepted: 11963

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow’s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2..M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.


解题心得:

  1. 有n个牛,每个牛要去牛x家开party,每个牛都只走最短路径,要求你输出哪只牛走的路程(来回)最远。
  2. 首先要明白的是边是单向边,然后考了一个思维,先按照原图,用牛x家为起点跑spfa可以得出每个牛开完party回家要走多远,然后将所有的边反向,同样从牛x家跑spfa,得出的就是每只牛从家去牛x家需要走多远,然后来回的路径求和就是一只牛要走的路程。得出最大值就行了。

#include <stdio.h>
#include <queue>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn = 1010;

bool vis[maxn];
int Time_to[maxn],Time_back[maxn],n,m,x,Time[maxn];
vector <pair <int,int> > ve_back[maxn],ve_to[maxn];

void spfa_back(int s) {
    memset(Time_back,0x7f,sizeof(Time_back));
    Time_back[s] = 0;
    queue <int> qu;
    qu.push(s);
    while(!qu.empty()) {
        int u = qu.front(); qu.pop();
        vis[u] = false;
        for(int i=0;i<ve_back[u].size();i++) {
            pair <int,int> temp = ve_back[u][i];
            int v = temp.first;
            int d = temp.second;
            if(Time_back[u] + d < Time_back[v]) {
                Time_back[v] = Time_back[u]+d;
                if(!vis[v]) {
                    qu.push(v);
                    vis[v] = true;
                }
            }
        }
    }
}

void spfa_to(int s) {
    memset(vis,0,sizeof(vis));
    memset(Time_to,0x7f,sizeof(Time_to));
    Time_to[s] = 0;
    queue <int> qu;
    qu.push(s);
    while(!qu.empty()) {
        int now = qu.front(); qu.pop();
        vis[now] = false;
        for(int i=0;i<ve_to[now].size();i++) {
            int v = ve_to[now][i].first;
            int d = ve_to[now][i].second;
            if(Time_to[now] + d < Time_to[v]) {
                Time_to[v] = Time_to[now] + d;
                if(!vis[v]) {
                    vis[v] = true;
                    qu.push(v);
                }
            }
        }
    }

    for(int i=1;i<=n;i++) {
        Time[i] = Time_to[i] + Time_back[i];
    }
}

void get_ans() {
    int Max = 0;
    for(int i=1;i<=n;i++)
        Max = max(Max,Time[i]);
    printf("%d",Max);
}

int main() {
    scanf("%d%d%d",&n,&m,&x);
    for(int i=0;i<m;i++) {
        int a,b,len;
        scanf("%d%d%d",&a,&b,&len);
        ve_to[b].push_back(make_pair(a,len));
        ve_back[a].push_back(make_pair(b,len));
    }

    spfa_back(x);
    spfa_to(x);
    get_ans();

    return 0;
}
原文地址:https://www.cnblogs.com/GoldenFingers/p/9107148.html