POJ 1300.Door Man 欧拉通路

Door Man
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 2596   Accepted: 1046

Description

You are a butler in a large mansion. This mansion has so many rooms that they are merely referred to by number (room 0, 1, 2, 3, etc...). Your master is a particularly absent-minded lout and continually leaves doors open throughout a particular floor of the house. Over the years, you have mastered the art of traveling in a single path through the sloppy rooms and closing the doors behind you. Your biggest problem is determining whether it is possible to find a path through the sloppy rooms where you: 

  1. Always shut open doors behind you immediately after passing through 
  2. Never open a closed door 
  3. End up in your chambers (room 0) with all doors closed 

In this problem, you are given a list of rooms and open doors between them (along with a starting room). It is not needed to determine a route, only if one is possible. 

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.
A single data set has 3 components: 

  1. Start line - A single line, "START M N", where M indicates the butler's starting room, and N indicates the number of rooms in the house (1 <= N <= 20). 
  2. Room list - A series of N lines. Each line lists, for a single room, every open door that leads to a room of higher number. For example, if room 3 had open doors to rooms 1, 5, and 7, the line for room 3 would read "5 7". The first line in the list represents room 0. The second line represents room 1, and so on until the last line, which represents room (N - 1). It is possible for lines to be empty (in particular, the last line will always be empty since it is the highest numbered room). On each line, the adjacent rooms are always listed in ascending order. It is possible for rooms to be connected by multiple doors! 
  3. End line - A single line, "END" 

Following the final data set will be a single line, "ENDOFINPUT". 

Note that there will be no more than 100 doors in any single data set.

Output

For each data set, there will be exactly one line of output. If it is possible for the butler (by following the rules in the introduction) to walk into his chambers and close the final open door behind him, print a line "YES X", where X is the number of doors he closed. Otherwise, print "NO".

Sample Input

START 1 2
1

END
START 0 5
1 2 2 3 3 4 4




END
START 0 10
1 9
2
3
4
5
6
7
8
9

END
ENDOFINPUT

Sample Output

YES 1
NO
YES 10

题目链接:http://poj.org/problem?id=1300

题意:有很多房间,编号为0,1,2,3,...。输入m,n。m为起始房间号;n为房间总数(1≤n≤20)。接下来n行列出了房间通向其他的房间号。(注意:空行也是输入,表示这个房间通向其他的房间号都已经出现了。)从m开始通过所有的门,通过后把门关上,关上了的门不能打开,最后回到0。

思路:最基础的欧拉通路的判断,判断是否是起点是m,终点是0的欧拉通路(默认是连通图)。主要要注意输入输出的格式。

代码:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int  door[30];
char s[100000];
int Init()
{
    int len=0;
    char ch;
    while((ch=getchar())&&ch!='
')
    {
        s[len++]=ch;
    }
    return len;
}
int main()
{
    int i,j,m,n;
    int len;
    int ans=0;
    while(scanf("%s",s)!=EOF)
    {
        len=strlen(s);
        if(len==10) break;
        scanf("%d%d",&m,&n);
        getchar();
        memset(door,0,sizeof(door));
        ans=0;
        for(i=0; i<n; i++)
        {
            len=Init();
            for(j=0; j<len; j++)
            {
                int num=0;
                while(j<len&&s[j]!=' ')
                {
                    num=num*10+(s[j]-'0');
                    j++;
                }
                ans++;
                door[i]++;
                door[num]++;
            }
        }
        scanf("%s",s);
        int even=0,odd=0;
        for(i=0; i<n; i++)
        {
            if(door[i]%2==0) even++;
            else odd++;
        }
        if(odd==0&&m==0) cout<<"YES "<<ans<<endl;
        else if(odd==2&&m!=0&&door[0]%2!=0&&door[m]%2!=0) cout<<"YES "<<ans<<endl;
        else cout<<"NO"<<endl;
    }
    return 0;
}
View Code
I am a slow walker,but I never walk backwards.
原文地址:https://www.cnblogs.com/GeekZRF/p/5459908.html