hdu 4334 Trouble

题目连接

http://acm.hdu.edu.cn/showproblem.php?pid=4334   

Trouble

Description

Hassan is in trouble. His mathematics teacher has given him a very difficult problem called 5-sum. Please help him.
The 5-sum problem is defined as follows: Given 5 sets S_1,...,S_5 of n integer numbers each, is there a_1 in S_1,...,a_5 in S_5 such that a_1+...+a_5=0?

Input

First line of input contains a single integer N (1≤N≤50). N test-cases follow. First line of each test-case contains a single integer n (1<=n<=200). 5 lines follow each containing n integer numbers in range [-10^15, 1 0^15]. I-th line denotes set S_i for 1<=i<=5.

Output

For each test-case output "Yes" (without quotes) if there are a_1 in S_1,...,a_5 in S_5 such that a_1+...+a_5=0, otherwise output "No".

Sample Input

2
2
1 -1
1 -1
1 -1
1 -1
1 -1
3
1 2 3
-1 -2 -3
4 5 6
-1 3 2
-4 -10 -1

Sample Output

No
Yes

简单哈希。。

#include<algorithm>
#include<iostream>
#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<vector>
#include<map>
using std::abs;
using std::min;
using std::find;
using std::pair;
using std::vector;
using std::multimap;
#define pb(e) push_back(e)
#define sz(c) (int)(c).size()
#define mp(a, b) make_pair(a, b)
#define all(c) (c).begin(), (c).end()
#define iter(c) __typeof((c).begin())
#define cls(arr, val) memset(arr, val, sizeof(arr))
#define cpresent(c, e) (find(all(c), (e)) != (c).end())
#define rep(i, n) for(int i = 0; i < (int)n; i++)
#define tr(c, i) for(iter(c) i = (c).begin(); i != (c).end(); ++i)
const int N = 1000007;
const int INF = 0x3f3f3f3f;
typedef long long ll;
struct Hash_Set {
    ll num[N << 1];
    int tot, head[N], next[N];
    inline void init() {
        tot = 0, cls(head, -1);
    }
    inline void insert(ll val) {
        ll u = abs(val) % N;
        num[tot] = val, next[tot] = head[u], head[u] = tot++;
    }
    inline bool find(ll val) {
        ll u = abs(val) % N;
        for(int i = head[u]; ~i; i = next[i]) {
            if(num[i] == val) return true;
        }
        return false;
    }

}hash;
ll A[5][210];
int main() {
#ifdef LOCAL
    freopen("in.txt", "r", stdin);
    freopen("out.txt", "w+", stdout);
#endif
    ll val;
    int t, n;
    scanf("%d", &t);
    while(t--) {
        hash.init();
        scanf("%d", &n);
        rep(i, 5) {
            rep(j, n) scanf("%lld", &A[i][j]);
        }
        rep(i, n) {
            rep(j, n) {
                val = A[0][i] + A[1][j];
                hash.insert(val);
            }
        }
        bool f = false;
        rep(i, n) {
            rep(j, n) {
                rep(k, n) {
                    val = A[2][i] + A[3][j] + A[4][k];
                    val = -val;
                    if(hash.find(val)) { f = true; break; }
                }
                if(f) break;
            }
            if(f) break;
        }
        puts(f ? "Yes" : "No");
    }
    return 0;
}
原文地址:https://www.cnblogs.com/GadyPu/p/4792966.html