HDU 1002 Sum Problem

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 223816    Accepted Submission(s): 54902

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 
Input
The input will consist of a series of integers n, one integer per line.
 
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 
Sample Input
1 100
 
Sample Output
1 5050
 
Author
DOOM III
 
思路:
 
代码:
#include <stdio.h>
#include <stdlib.h>
int main()
{

    int
n,sum=0,i;
    while
(scanf("%d",&n)!=EOF)
    {

      for
(i=1;i<=n;i++)
      sum=sum+i;
      printf("%d ",sum);
      sum=0;
      }
}
原文地址:https://www.cnblogs.com/GODLIKEING/p/3290612.html