HDU1358 Period

HDU1358 Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 675    Accepted Submission(s): 321


Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 
Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 
Sample Input
3
aaa
12
aabaabaabaab
0
 
Sample Output
Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4
*******************************************************************
题目大意:一个字符串,问从头到某个位置,字符串的前缀最多重复了多少次。比方aaaa的字符串,到第二个字符,前缀a重复了两次,到第三个字符,前缀a重复了三次,到第四个字符,前缀a重复了四次,前缀aa重复了两次,但我们要得到的是重复了四次。
解题思路:考察KMP算法中的p数组。p数组是基本的,然后,在p数组中考察,p[6]=4,我们能知道的是,s[1]=s[3]=s[5],s[2]=s[4]=s[6],其实只要在p[k]=u时,当u整除(k-u)的时候,就是满足题目要求的时候。
#include <stdio.h>
#include <string.h>
#define N 1000000

int n;
char str[N];
int p[N];

void run(void)
{
    memset(p,-1,sizeof(p));
    for(int i=1;i<n;i++)
    {
        int k=p[i-1];
        while(1)
        {
            if(str[k+1]==str[i])
            {
                p[i]=k+1;
                if((i+1)%(i-p[i])==0)
                    printf("%d %d\n",i+1,(i+1)/(i-p[i]));
                break;
            }
            if(k==-1)break;
            k=p[k];
        }
    }
}

int main()
{
    int id=0;
    while(scanf("%d",&n)==1&&n)
    {
        getchar();
        gets(str);
        printf("Test case #%d\n",++id);
        run();
        puts("");
    }
}
原文地址:https://www.cnblogs.com/Fatedayt/p/2274744.html