POJ3252 Round Numbers

POJ3252 Round Numbers
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 4877   Accepted: 1664

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start..Finish

Sample Input

2 12

Sample Output

6
********************************************************
题目大意:对于某个数n,把它写成二进制,如果他的二进制中0的个数不比1的个数少,那么这个数就是一个round数,求给定一个区间它中间的round数的个数。
解题思路:推数学公式。真纠结。
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <string>
using namespace std;

int dp[40][40];

string cha(int a)
{
    if(a==1)return "1";
    if(a==0)return "0";
    string temp;
    while(a)
    {
        temp.push_back(a%2+'0');
        a/=2;
    }
    string kk;
    int len=temp.size();
    for(int i=len-1;i>=0;i--)
        kk.push_back(temp[i]);
    return kk;
}

int rans(string str)
{
    int ret=0,len=str.size();
    if(len==1)return 0;
    if(len==2)return 1;
    if(len==3)return 2;
    for(int i=len-2;i>=1;i--)
        if(i&1)
            ret+=((1<<i)>>1);
        else
            ret+=((1<<i)-dp[i][i/2])>>1;
    int now=1;
    for(int h=1;h<len;h++)
    {
        now--;
        if(str[h]=='1')
        {
            int n=len-h-1;
            if(n==0&&now<=0)
            {
                ret++;
                if(now<=-1)ret++;
                now+=2;
                break;
            }
            for(int i=n;2*i-n>=now;i--)
                ret+=dp[n][i];
            now+=2;
        }
    }
    if(str[len-1]=='0'&&now<=0)ret++;
    return ret;
}

int main()
{
    for(int i=1;i<=31;i++)
    {
        dp[i][0]=1;
        for(int j=1;j<i;j++)
        {
            int a=i-j+1,b=j;
            dp[i][j]=dp[i][j-1]*a/b;
        }
        dp[i][i]=1;
    }
    int sta,ed;
    cin>>sta>>ed;
    cout<<rans(cha(ed))-rans(cha(sta-1))<<endl;
}

  


也许有挫折,但这些,怎能挡住湘北前进的步伐
原文地址:https://www.cnblogs.com/Fatedayt/p/2232967.html