POJ1094 Sorting It All Out

POJ1094 Sorting It All Out

Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 18073 Accepted: 6145

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 

Sorted sequence cannot be determined. 

Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6

A<B

A<C

B<C

C<D

B<D

A<B

3 2

A<B

B<A

26 1

A<Z

0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.

Inconsistency found after 2 relations.

Sorted sequence cannot be determined.

*******************************************************************

拓扑排序,第一次写,可惜不是一A是二A,5555.

#include<iostream>
#include<string.h>
#include<vector>
using namespace std;

int gra[30][30],n;
vector<int>ls;
int vis[30],mark[30];

void dfs(int s)
{
    vis[s]++;
    if(vis[s]>=2)return ;
    for(int i=0;i<n;i++)
        if(gra[s][i])
            dfs(i);
}

int main()
{
    int m,num;
    while(cin>>n>>m,n+m)
    {
        num=n;
        memset(gra,0,sizeof(gra));
        memset(mark,0,sizeof(mark));
        char str[10];
        int flag=0;
        for(int i=1;i<=m;i++)
        {
            cin>>str;
            if(flag)continue;
            int one=str[0]-'A',two=str[2]-'A';
            if(mark[two]==0)num--;
            mark[two]++;
            gra[one][two]=1;
            memset(vis,0,sizeof(vis));
            dfs(one);
            if(vis[one]>1)
            {
                flag=1;
                cout<<"Inconsistency found after "<<i<<" relations."<<endl;
            }
            if(num!=1)continue;
            int temp[30];
            memcpy(temp,mark,sizeof(mark));
            ls.clear();
            for(int j=1;j<=n;j++)
            {
                int k=-1;
                for(int l=0;l<n;l++)
                    if(temp[l]==0)
                    {
                        k=l;break;
                    }
                if(k==-1)break;
                ls.push_back(k);
                temp[k]=-1;
                for(int l=0;l<n;l++)
                    if(gra[k][l])
                        temp[l]--;
            }
            int gu=0;
            for(int j=0;j<n-1;j++)
            {
                memset(vis,0,sizeof(vis));
                dfs(ls[j]);
                if(vis[ls[j+1]]==0){gu=1;break;}
            }
            if(ls.size()==n&&gu==0)
            {
                flag=1;
                cout<<"Sorted sequence determined after "<<i<<" relations: ";
                for(int j=0;j<n;j++)
                    cout<<(char)(ls[j]+'A');
                cout<<"."<<endl;
            }
        }
        if(flag==0)
            cout<<"Sorted sequence cannot be determined."<<endl;
    }
}

  

原文地址:https://www.cnblogs.com/Fatedayt/p/2178066.html