C语言编程练习41:ACboy needs your help again!

ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

InputThe input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.OutputFor each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.Sample Input
4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT
Sample Output
1
2
2
1
1
2
None
2
3

栈与队列的使用

#include <iostream>
#include <cstdio>
#include <string>
#include <algorithm>
#include <stack>
#include <queue>

using namespace std;

int main()
{
    int t;
    cin>>t;
    getchar();
    while(t--)
    {
        int n;
        scanf("%d ",&n);
        string s1,s2;
        cin >> s1;
        if(s1=="FIFO")
        {
            queue<int>qu;
            while(n--)
            {
                cin>>s2;
                if(s2=="IN")
                {
                    int num;
                    cin>>num;
                    qu.push(num);
                }
                else
                {
                    if(qu.empty())
                    {
                        cout<<"None"<<endl;
                        
                    }
                    else
                    {
                        cout<<qu.front()<<endl;
                        qu.pop();
                    }
                    
                } 
                
            }
        }
         if(s1=="FILO")
        {
            stack<int>st;
            while(n--)
            {
                cin>>s2;
                if(s2=="IN")
                {
                    int num;
                    cin>>num;
                    st.push(num);
                }
                else
                {
                    if(st.empty())
                    {
                        cout<<"None"<<endl;
                        
                    }
                    else
                    {
                        cout<<st.top()<<endl;
                        st.pop();
                    }
                    
                }
                
            }
        }
    }
    
    return 0;
}
原文地址:https://www.cnblogs.com/FantasticDoubleFish/p/14345266.html