C语言编程练习39:Solving Oder

Welcome to HDU to take part in the first CCPC girls' competition!




As a pretty special competition, many volunteers are preparing for it with high enthusiasm.
One thing they need to do is blowing the balloons.

Before sitting down and starting the competition, you have just passed by the room where the boys are blowing the balloons. And you have found that the number of balloons of different colors are strictly different.

After thinking about the volunteer boys' sincere facial expressions, you noticed that, the problem with more balloon numbers are sure to be easier to solve.

Now, you have recalled how many balloons are there of each color.
Please output the solving order you need to choose in order to finish the problems from easy to hard.
You should print the colors to represent the problems.

which indicates the case number.
And as for each case, the first line is an integer n, which is the number of problems.
Then there are n lines followed, with a string and an integer in each line, in the i-th line, the string means the color of ballon for the i-th problem, and the integer means the ballon numbers.

It is guaranteed that:
T is about 100.
1n10.
1 string length 10.
1 bolloon numbers 83


InputThe first line is an integer T.(there are 83 teams :p)
For any two problems, their corresponding colors are different.
For any two kinds of balloons, their numbers are different.
OutputFor each case, you need to output a single line.
There should be n strings in the line representing the solving order you choose.
Please make sure that there is only a blank between every two strings, and there is no extra blank.
Sample Input
3
3
red 1
green 2
yellow 3
1
blue 83
2
red 2
white 1
Sample Output
yellow green red
blue
red white
#include <iostream>
#include <cstdio>
#include <string>
#include <algorithm>

using namespace std;
struct ss
{
    char color[50];
    int pro;
}ballon[500];

bool cmp(ss x,ss y)
{
    return x.pro>y.pro;
}
int main()
{
    int T;
    cin >> T;
    while(T--)
    {
        int n;
        cin >> n;
        for(int i=0;i<n;i++)
        {
            cin >> ballon[i].color >>ballon[i].pro;
        }
        sort(ballon,ballon+n,cmp);
        for(int i=0;i<n-1;i++)
        {
            cout << ballon[i].color << ' ';
        }
        cout << ballon[n-1].color << endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/FantasticDoubleFish/p/14345023.html