hdu1002

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 141857    Accepted Submission(s): 26917

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 
Sample Input
2 1 2 112233445566778899 998877665544332211
 
Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 
 
 
 
//此题为高精度,不可大意
#include<stdio.h>
#include<string.h>
int main()
{
 char op1[1002],op2[1002];
 int c,i,j,n,m,s1[1002],s2[1002],len1,len2,count;
 count=1;
 scanf("%d",&n);
 m=n;
 while(m--)
 {
  memset(s1,0,1002*sizeof(int));
  memset(s2,0,1002*sizeof(int));
  scanf("%s",op1);
  scanf("%s",op2);
  len1=strlen(op1);
  len2=strlen(op2);
  c=0;
  for(i=len1-1;i>=0;i--)
   s1[c++]=op1[i]-'0';//把顺序颠倒
  c=0;
  for(i=len2-1;i>=0;i--)
   s2[c++]=op2[i]-'0';
  for(i=0;i<1002;i++)
  {
   s1[i]+=s2[i];
   if(s1[i]>=10)
   {
    s1[i]-=10;//逢十进位
    s1[i+1]++;
   }
  }
  printf("Case %d:\n",count++);
  printf("%s + %s = ",op1,op2);
  for(i=1001;i>=0;i--)
   if(s1[i])//清掉前导0
    break;
  for(j=i;j>=0;j--)
   printf("%d",s1[j]);
   printf("\n");
 }
  printf("\n");
  if(count!=n+1)
 return 0;
}
 
原文地址:https://www.cnblogs.com/Deng1185246160/p/2940402.html