【POJ 2752 Seek the Name, Seek the Fame】

Time Limit: 2000MS
Memory Limit: 65536K

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:
Step1. Connect the father's name and the mother's name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).
Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.
Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

Source

POJ Monthly--2006.01.22,Zeyuan Zhu

题解:

     ①题目要求求出一个串的所有和某后缀相等的前缀的长度。

     ②KMP的NEXT数组递归求解

#include<stdio.h>
#include<cstring>
#define go(i,a,b) for(int i=a;i<=b;i++)
using namespace std;const int N=1000003;
int m,f[N],j,S[N],s;char P[N];
int main()
{
	f[0]=f[1]=0;
	while(~scanf("%s",P))
	{
		m=strlen(P);
		go(i,1,m-1){j=f[i];while(j&&P[j]!=P[i])j=f[j];f[i+1]=P[i]==P[j]?j+1:0;}
		j=m;while(j)S[++s]=j,j=f[j];while(s)printf("%d ",S[s--]);puts("");
	}
	return 0;
}//Paul_Guderian

那年我二十五岁,转眼许多年过去我真的成功了

我的歌传遍了大街小巷,我有了一个家和可爱的女儿,

有了一群志同道合的朋友……————————汪峰《那年我五岁》

原文地址:https://www.cnblogs.com/Damitu/p/7656259.html