HDU-ACM课堂作业 Tian Ji -- The Horse Racing

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 212   Accepted Submission(s) : 48
Problem Description
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 
Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 
Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 
Sample Input
3 92 83 71 95 87 74 2 20 20 20 20 2 20 19 22 18 0
 
Sample Output
200 0 0
 
思路:贪心算法
先将田忌与国王的马从小到大排序,从最小的马开始考虑
①若田忌最小的马大于国王,则先赢一场。
②若田忌最小大马小于国王,则和国王最大马同归于尽。输一场
若最小的马相等,则考虑最大的马
#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include <iomanip>
#include<math.h>
using namespace std;

int main()
{
    int n = 0;
    while (cin >> n&&n!=0) {
        int king[1024] = { 0 };
        int tj[1024] = { 0 };
        int win=0, fail = 0;
        for (int i = 0; i < n; i++)
            cin >> tj[i];
        for (int i = 0; i < n; i++)
            cin >> king[i];
        sort(king, king + n);
        sort(tj, tj + n);
        int kingBegin = 0, kingEnd = n - 1;
        int tjBegin = 0, tjEnd = n - 1;
        while(tjBegin<=tjEnd) {
            if (tj[tjBegin] > king[kingBegin]) {
                win++;
                tjBegin++;
                kingBegin++;
            }
            else if (tj[tjBegin] < king[kingBegin]) {
                fail++;
                kingEnd--;
                tjBegin++;
            }
            else {
                    if (tj[tjEnd] > king[kingEnd])
                    {
                        win++;
                        tjEnd--;
                        kingEnd--;
                    }
                    else
                    {
                        if (tj[tjBegin] < king[kingEnd])
                            fail++;
                        kingEnd--;
                        tjBegin++;
                    }
                }
            }
        cout << 200*(win - fail) << endl;
    }
}
①若最大田忌最大的马更强,则此时一胜一平。
②若田忌最大的马更弱,则用最小的马换最大的马。一胜一负。
 
 
 
原文地址:https://www.cnblogs.com/DaiShuSs/p/9772488.html