Catch That Cow POJ 3278

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
#include<stdio.h>
#include<string.h>
const int maxn = 100001;
bool vis[maxn];
int n, k;
struct Node
{
    int x, step;
};
Node q[maxn];
int bfs()
{
    int i;
    Node now, next;
    int head, tail;
    head = tail = 0;
    q[tail].x = n;//手动维护一个队列 为啥我用stl的队列会崩
    q[tail].step = 0; tail++;
    vis[n] = true;
    while (head<tail)
    {
        now = q[head];//取队首
        head++;//弹出对首
        for (i = 0; i<3; i++)
        {
            if (i == 0) next.x = now.x - 1;
            else if (i == 1) next.x = now.x + 1;
            else next.x = 2 * now.x;
            if (next.x<0 || next.x >= maxn) continue;//剪枝、排除越界
            if (!vis[next.x])
            {
                vis[next.x] = true;
                next.step = now.step + 1;
                q[tail].x = next.x; q[tail].step = next.step; tail++;
                if (next.x == k) return next.step;
            }
        }
    }
}
int main()
{
    while (scanf("%d%d", &n, &k) != EOF)
    {
        memset(vis, false, sizeof(vis));
        if (n >= k) printf("%d\n", n - k);
        else printf("%d\n", bfs());
    }
    return 0;
}
原文地址:https://www.cnblogs.com/CuteAbacus/p/9492118.html