HDU6438(优先队列+思维)

传送门

题面:

The Power Cube is used as a stash of Exotic Power. There are nn cities numbered 1,2,…,n1,2,…,n where allowed to trade it. The trading price of the Power Cube in the ii-th city is aiai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the ii-th city and choose exactly one of the following three options on the ii-th day: 

1. spend aiai dollars to buy a Power Cube 
2. resell a Power Cube and get aiai dollars if he has at least one Power Cube 
3. do nothing 

Obviously, Noswal can own more than one Power Cubes at the same time. After going to the nn cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning. 

Input

There are multiple test cases. The first line of input contains a positive integer TT (T≤250T≤250), indicating the number of test cases. For each test case: 
The first line has an integer nn. (1≤n≤1051≤n≤105) 
The second line has nn integers a1,a2,…,ana1,a2,…,an where aiai means the trading price (buy or sell) of the Power Cube in the ii-th city. (1≤ai≤1091≤ai≤109) 
It is guaranteed that the sum of all nn is no more than 5×1055×105. 

Output

For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.

Sample Input

3
4
1 2 10 9
5
9 5 9 10 5
2
2 1

Sample Output

16 4
5 2
0   

Hint

In the first case, he will buy in 1, 2 and resell in 3, 4. 
         
  profit = - 1 - 2 + 10 + 9 = 16
In the second case, he will buy in 2 and resell in 4. 
         
  profit = - 5 + 10 = 5
In the third case, he will do nothing and earn nothing. 
         
  profit = 0

题目意思:

    有n个城市,第i天你会达到第i个城市,在第i个城市中,你可以用ai元购买一个物品,或者用ai元卖掉一个物品,你可以同时保存多个物品。最开始你身上没有物品,但是又无限的金钱,现在要求你从城市1走到城市n,问你最大的收益是多少。

题目分析:

    听说这又是个CF的原题?(CF867E

    首先考虑这样的一个问题:假设我在第i个城市入货Ai元物品,在i+1个城市发现,此时我们考虑将物品卖出,则此时的利润为:。同时,倘若我在第i+2个城市发现,则我们也考虑将物品卖出,则此时的利润为:,而我们发现,对于这三天而言,总利润为:,我们发现,对于这种状态,中间商对答案是没有影响的(换句话说,就是没有中间商是赚差价)

    因为要求我们赚的最多,因此我们必定是优先将最贵的跟买入最便宜的相减,因此我们可以考虑对价值开一个小根堆进行维护。

    而倘若我们发现在第i天中,Ai>之前的最小值,则此时的Ai可能作为中间商,因此我们可以将Ai压入队列两次,代表Ai可能作为中间商影响答案。

    至于统计次数cnt,我们发现,倘若Ai是中间商(即Ai在队列内还影响答案了),则我们则不需要统计这一次的记录,否则我们需要将次数cnt+1即可。

代码:

#include <bits/stdc++.h>
#define maxn 100005
using namespace std;
priority_queue<int,vector<int>,greater<int> >que;//优先队列
map<int,int>mp;
typedef long long ll;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        while(!que.empty()) que.pop();
        mp.clear();
        scanf("%d",&n);
        ll res=0,cnt=0;
        for(int i=1;i<=n;i++){
            int x;
            scanf("%d",&x);
            if(!que.empty()&&que.top()<x){
                int now=que.top();
                que.pop();
                res+=x-now;//统计答案
                que.push(x);//对x压入队列两次
                cnt++;//次数+1
                if(mp[now]){//如果当前队顶元素在之前存在过,则证明它为中间商,则需要消除这次的记录数
                     cnt--;
                     mp[now]--;
                }
                mp[x]++;
            }
            que.push(x);
        }
        cout<<res<<" "<<cnt*2<<endl;
    }
}
原文地址:https://www.cnblogs.com/Chen-Jr/p/11007219.html