HDOJ 2577 How To Type

可以这样设定状态,定义两个数组on[],off[]。
               on表示已经输入了i个字母且lock是on状态的最小按键次数
               off表示已经输入了i个字母且lock是off状态的最小按键次数
               初始时 on[0] = 1, off[0] = 0;
               转移方程:
                     大写字母:               
                           on = min(on[i-1] + 1, off[i-1] + 2);//直接打字母||打字母开灯
                           off = min(on[i-1] + 2, off[i-1] + 2);
                     小写字母:
                           on = min(on[i-1] + 2, off[i-1] + 2);
                           off = min(on[i-1] + 2, off[i-1] + 1);
               显然ans = min(on[len] + 1, off[len]);//要关灯

How to Type

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2497    Accepted Submission(s): 1169


Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
 

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
 

Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
 

Sample Input
3PiratesHDUacmHDUACM
 

Sample Output
888
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8.The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8
 

Author
Dellenge
 

Source
 

Recommend
lcy
 

#include <iostream>
#include <cstring>

using namespace std;

int main()
{
    int T;
    cin>>T;
while(T--)
{
    int on[111],off[111];
    on[0]=1;off[0]=0;
    char ch[111];
    cin>>ch;
    int len=strlen(ch);
    for(int i=1;i<=len;i++)
    {
        if(ch[i-1]<='Z')///A~~Z
        {
            on=min(on[i-1]+1,off[i-1]+2);
            off=min(on[i-1]+2,off[i-1]+2);
        }
        else///a~~z
        {
            on=min(on[i-1]+2,off[i-1]+2);
            off=min(off[i-1]+1,on[i-1]+2);
        }
    }

    cout<<min(off[len],on[len]+1)<<endl;
}

    return 0;
}

原文地址:https://www.cnblogs.com/CKboss/p/3351051.html