HDOJ 1160 FatMouse's Speed

路径记录+LIS

FatMouse's Speed

                                                          Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                                      Total Submission(s): 6900    Accepted Submission(s): 3017
                                                                                                                                      Special Judge


Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed. 
 

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

W[m[1]] < W[m[2]] < ... < W[m[n]]

and 

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 
 

Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900
 

Sample Output
4
4
5
9
7
 

Source
 

Recommend
Ignatius
 



#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>

using namespace std;

struct Fa
{
    int id;
    int speed;
    int weight;
}mouse[1100];

int dp[1100];

int fa[1100];

bool cmp(Fa a,Fa b)
{
    return a.weight<=b.weight;
}

int main()
{
    int S,W;
    int cur=0;
while(scanf("%d%d",&W,&S)!=EOF)
{
    mouse[cur].speed=S;
    mouse[cur].weight=W;
    mouse[cur].id=cur;
    cur++;
}

    sort(mouse,mouse+cur,cmp);

/*
    for(int i=0;i<cur;i++)
        cout<<mouse.weight<<" , "<<mouse.speed<<endl;
  cout<<"___________________\n";
*/
    for(int i=0;i<=cur;i++)
       {
           dp=1;
           fa=i;
       }

    for(int i=1;i<cur;i++)
    {
        for(int j=0;j<i;j++)
        {
            if(mouse.speed<mouse[j].speed&&dp<dp[j]+1&&mouse.weight>mouse[j].weight)
               {
                   dp=dp[j]+1;
                   fa=j;
               }
        }
    }
/*
    for(int i=0;i<cur;i++)
        cout<<dp<<" ";
    cout<<endl<<endl;
    for(int i=0;i<cur;i++)
        cout<<fa<<" ";

    cout<<"\n----------------\n";
*/
   int p=-1,maxn=-1;
   for(int i=0;i<cur;i++)
   {
       if(dp>maxn)
       {
           maxn=dp;
           p=i;
       }
   }

    int ans[1100];
    int cnt=0;
    while(p!=fa[p])
    {
        ans[cnt]=mouse[p].id;
        p=fa[p];
        cnt++;
    }
    cout<<maxn<<endl;
    cout<<mouse[p].id+1<<endl;
    for(int i=cnt-1;i>=0;i--)
        cout<<ans+1<<endl;

    return 0;
}


原文地址:https://www.cnblogs.com/CKboss/p/3351041.html