ZOJ 1060 Sorting It All Out (topo-sort)


这就是人生中的第一道图论题???
   还是看别人题解做的。。。。。

Sorting It All Out

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 1   Accepted Submission(s) : 1
Problem Description
An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not. 

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

 

Source
East Central North America 2001
 

拓扑排序:
1:找到入度为0的节点(找不到说明有环)   2:输出该节点,并删除与该节点有关的边(入度减1)   3:重复以上两步


#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int MAXN=30;

bool adj[MAXN][MAXN];
int in_degree[MAXN];
char str[MAXN];
int n,m;

int topo()
{
    bool flag=true;

    memset(in_degree,0,sizeof(in_degree));
    memset(str,'',sizeof(str));

    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            if(adj[j])
            {
                in_degree[j]++;
            }
        }
    }

    for(int i=1;i<=n;i++)
    {
        int k=0;
        for(int j=1;j<=n;j++)
        {
            if(in_degree[j]==0)
            {
                if(k==0)
                {
                    k=j;
                }
                else
                {
                    flag=false;
                }
            }
        }

        if(k==0) return 0;

        in_degree[k]=-1;

        str[i-1]=k+'A'-1;

        for(int j=1;j<=n;j++)
        {
            if(adj[k][j])
            {
                in_degree[j]--;
            }
        }
    }

    if(flag) return 1;
    else return 2;

}

int main()
{
    int a,b,result;
    char s[4];
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0&&m==0) break;
        memset(adj,false,sizeof(adj));
        bool h=false;
        for(int i=1;i<=m;i++)
        {
            scanf("%s",s);
            a=s[0]-'A'+1;  b=s[2]-'A'+1;
            adj[a]=true;
            if(h) continue;

            result=topo();

            if(result==1)
            {
                printf("Sorted sequence determined after %d relations: %s. ",i,str);
                h=true;
            }
            if(result==0)
            {
                printf("Inconsistency found after %d relations. ",i);
                h=true;
            }
        }
        if(!h)
        printf("Sorted sequence cannot be determined. ");
    }

    return 0;
}

原文地址:https://www.cnblogs.com/CKboss/p/3350979.html