HDOJ 1233 还是畅通工程

还是kruskal。。。。

还是畅通工程

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19402    Accepted Submission(s): 8618


Problem Description
某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。
 

Output
对每个测试用例,在1行里输出最小的公路总长度。
 

Sample Input
3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0
 

Sample Output
3
5
Hint
Hint
Huge input, scanf is recommended.
 

Source
 

Recommend
JGShining
 


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

struct Node
{
    int st;
    int ed;
    int val;
}p[12000];
int Fa[12000],Rank[12000],save[12000];
int n;
bool cmp(Node a,Node b)
{
    return a.val<=b.val;
}

int Find_Father(int x)
{
    int tot=0;
    while(x!=Fa[x])
    {
        save[tot++]=x;
        x=Fa[x];
    }
    for(int i=0;i<tot;i++)
        Fa[save]=x;
    return x;
}

int Union_Set(int st,int ed,int val)
{
    int Father_a=Find_Father(st);
    int Father_b=Find_Father(ed);

    if(Father_a==Father_b) return 0;

    if(Rank[Father_a]<=Rank[Father_b])
    {
        Fa[Father_b]=Father_a;
        Rank[Father_a]+=Rank[Father_b];
    }
    else
    {
        Fa[Father_a]=Father_b;
        Rank[Father_b]+=Rank[Father_a];
    }
    return val;
}

int main()
{
while(scanf("%d",&n)!=EOF&&n)
{
    int a,b,c;
    int tot=0;
    for(int i=1;i<=((n-1)*n)/2;i++)
    {
        scanf("%d%d%d",&a,&b,&c);
        p[tot].st=a;
        p[tot].ed=b;
        p[tot].val=c;
        tot++;
        p[tot].ed=a;
        p[tot].st=b;
        p[tot].val=c;
        tot++;
    }

    sort(p,p+tot,cmp);

    for(int i=0;i<tot;i++)
    {
        Fa=i;
        Rank=1;
    }

    int sum=0;
    for(int i=0;i<tot;i++)
    {
        sum+=Union_Set(p.st,p.ed,p.val);
    }

    printf("%d ",sum);
}

    return 0;
}

原文地址:https://www.cnblogs.com/CKboss/p/3350958.html