HDOJ 1394 Minimum Inversion Number

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7428    Accepted Submission(s): 4560


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
10
1 3 6 9 0 8 5 7 4 2
 

Sample Output
16
 

Author
CHEN, Gaoli
 

Source
 

Recommend
Ignatius.L
 



#include <iostream>
#include <cstdio>
#include <cstring>
#define cls(x) memset((x),0,sizeof((x)));

using namespace std;

int a[5100],x[5100],n,cnt,ans,sum;

int main()
{
while(scanf("%d",&n)!=EOF)
{
    sum=0;cls(a);cls(x);
    for(int i=0;i<n;i++)
    {
        scanf("%d",&a);cnt=0;
        for(int j=0;j<i;j++)
        {
            if(a[j]>a)
                cnt++;
        }
        sum+=cnt;
    }
    for(int i=0;i<n;i++)
    {
        cnt=0;
        for(int j=0;j<n;j++)
        {
            if(a[j]<a&&i!=j)
                cnt++;
        }
        x=cnt;
    }
    ans=sum;
    for(int i=0;i<n;i++)
    {
        sum=sum-2*x+n-1;
        ans=min(sum,ans);
    }

    printf("%d ",ans);
}
    return 0;
}

原文地址:https://www.cnblogs.com/CKboss/p/3350936.html