POJ 3274 Gold Balanced Lineup



Gold Balanced Lineup
Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 10924Accepted: 3244

Description

Farmer John's N cows (1 ≤ N ≤ 100,000) share many similarities. In fact, FJ has been able to narrow down the list of features shared by his cows to a list of only K different features (1 ≤ K ≤ 30). For example, cows exhibiting feature #1 might have spots, cows exhibiting feature #2 might prefer C to Pascal, and so on.

FJ has even devised a concise way to describe each cow in terms of its "feature ID", a single K-bit integer whose binary representation tells us the set of features exhibited by the cow. As an example, suppose a cow has feature ID = 13. Since 13 written in binary is 1101, this means our cow exhibits features 1, 3, and 4 (reading right to left), but not feature 2. More generally, we find a 1 in the 2^(i-1) place if a cow exhibits feature i.

Always the sensitive fellow, FJ lined up cows 1..N in a long row and noticed that certain ranges of cows are somewhat "balanced" in terms of the features the exhibit. A contiguous range of cows i..j is balanced if each of the K possible features is exhibited by the same number of cows in the range. FJ is curious as to the size of the largest balanced range of cows. See if you can determine it.

Input

Line 1: Two space-separated integers, N and K
Lines 2..N+1: Line i+1 contains a single K-bit integer specifying the features present in cow i. The least-significant bit of this integer is 1 if the cow exhibits feature #1, and the most-significant bit is 1 if the cow exhibits feature #K.

Output

Line 1: A single integer giving the size of the largest contiguous balanced group of cows.

Sample Input

7 3
7
6
7
2
1
4
2

Sample Output

4

Hint

In the range from cow #3 to cow #6 (of size 4), each feature appears in exactly 2 cows in this range

Source

USACO 2007 March Gold 


#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

const int MAXHASH=100007;
int n,k,a;
int bit[100007][32];
int head[MAXHASH+10],next[MAXHASH+10];//散列表 拉链法。。。。

int hash(int v[])
{
    int h=0;
    for(int i=0;i<k;i++)
    {
        h=((h<<2)+v>>4)^(v<<10);//牛逼的。。。数组哈希函数(什么折叠法。。。)
    }
    h=h%MAXHASH;
    if(h<0)
        h+=MAXHASH;
    return h;
}

int main()
{
    scanf("%d%d",&n,&k);
    memset(head,-1,sizeof(head));

    int ans=0;

    for(int i=1;i<=n;i++)
    {
        scanf("%d",&a);
        for(int j=0;j<k;j++)
        {
            bit[j]=a&1;
            a=a>>1;
        }
    }

    for(int i=2;i<=n;i++)
    {
        for(int j=0;j<k;j++)
        {
            bit[j]+=bit[i-1][j];
        }
    }

    for(int i=0;i<=n;i++)
    {
        int tmp=bit[0];
        for(int j=0;j<k;j++)
        {
            bit[j]-=tmp;
        }
        int h=hash(bit);
        bool Find=false;
        for(int e=head[h];~e;e=next[e])
        {
            if(memcmp(bit[e],bit,sizeof(bit[e]))==0)
            {
                Find=true;
                ans=max(ans,i-e);
                break;
            }
        }
        if(!Find)
        {
            next=head[h];
            head[h]=i;
        }
    }
    printf("%d ",ans);
    return 0;
}
* This source code was highlighted by YcdoiT. ( style: Codeblocks )

原文地址:https://www.cnblogs.com/CKboss/p/3350867.html