ZOJ 2770 Burn the Linked Camp



Burn the Linked Camp

Time Limit: 2 Seconds      Memory Limit: 65536 KB

It is well known that, in the period of The Three Empires, Liu Bei, the emperor of the Shu Empire, was defeated by Lu Xun, a general of the Wu Empire. The defeat was due to Liu Bei's wrong decision that he divided his large troops into a number of camps, each of which had a group of armies, and located them in a line. This was the so-called "Linked Camps".

Let's go back to that time. Lu Xun had sent many scouts to obtain the information about his enemy. From his scouts, he knew that Liu Bei had divided his troops into n camps, all of which located in a line, labeled by 1..n from left to right. The ith camp had a maximum capacity of Ci soldiers. Furthermore, by observing the activities Liu Bei's troops had been doing those days, Lu Xun could estimate the least total number of soldiers that were lived in from the ith to the jth camp. Finally, Lu Xun must estimate at least how many soldiers did Liu Bei had, so that he could decide how many troops he should send to burn Liu Bei's Linked Camps.

Input:

There are multiple test cases! On the first line of each test case, there are two integers n (0<n<=1,000) and m (0<=m<=10,000). On the second line, there are n integers C1��Cn. Then m lines follow, each line has three integers i, j, k (0<i<=j<=n, 0<=k<2^31), meaning that the total number of soldiers from the ith camp to the jth camp is at least k.

Output:

For each test case, output one integer in a single line: the least number of all soldiers in Liu Bei's army from Lu Xun's observation. However, Lu Xun's estimations given in the input data may be very unprecise. If his estimations cannot be true, output "Bad Estimations" in a single line instead.

Sample Input:

3 2
1000 2000 1000
1 2 1100
2 3 1300
3 1
100 200 300
2 3 600

Sample Output:

1300
Bad Estimations


Author: ZHOU, Yuan
Source: ZOJ Monthly, October 2006



#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>

using namespace std;

const int MaxV=1111;
const int MaxE=51111;
const int INF=0x3f3f3f3f;

int n,m;

typedef struct
{
    int to,next,w;
}Edge;

Edge E[MaxE];
int Adj[MaxV],Size;

void Init()
{
    Size=0;
    memset(Adj,-1,sizeof(Adj));
}

void Add_Edge(int u,int v,int c)
{
    E[Size].to=v; E[Size].w=c;
    E[Size].next=Adj[u];
    Adj[u]=Size++;
}

bool SPFA()
{
    queue<int> q;
    int dist[MaxV],cnt[MaxV];
    bool inQue[MaxV];
    for(int i=0;i<=n+10;i++)
    {
        dist[i]=-INF;
    }
    memset(inQue,false,sizeof(inQue));
    memset(cnt,0,sizeof(cnt));
    dist[0]=0; inQue[0]=true;
    q.push(0);
    while(!q.empty())
    {
        int u=q.front(); q.pop();
        for(int i=Adj[u];~i;i=E[i].next)
        {
            int v=E[i].to;
            if(dist[v]<dist[u]+E[i].w)
            {
                dist[v]=dist[u]+E[i].w;
                if(!inQue[v])
                {
                    inQue[v]=true;
                    q.push(v);
                }
                cnt[v]++;
                if(cnt[v]>n)
                    return false;
            }
        }
        inQue[u]=false;
    }
    printf("%d ",dist[n]);
    return true;
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        int c[MaxV]; Init();
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++)
            scanf("%d",&c[i]);
        for(int i=0;i<m;i++)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            Add_Edge(a-1,b,c);
        }
        for(int i=1;i<=n;i++)
        {
            Add_Edge(i,i-1,-c[i]);
            Add_Edge(i-1,i,0);
            Add_Edge(0,i,0);
        }
        if(SPFA()==false)
        {
            puts("Bad Estimations");
        }
    }
    return 0;
}

* This source code was highlighted by YcdoiT. ( style: Codeblocks )

原文地址:https://www.cnblogs.com/CKboss/p/3291089.html