数据结构实验之查找五:平方之哈希表

                          数据结构实验之查找五:平方之哈希表

Time Limit: 400MS Memory Limit: 65536KB

Problem Description

给定的一组无重复数据的正整数,根据给定的哈希函数建立其对应hash表,哈希函数是H(Key)=Key%P,P是哈希表表长,P是素数,处理冲突的方法采用平方探测方法,增量di=±i^2,i=1,2,3,...,m-1

Input

输入一组测试数据,数据的第1行给出两个正整数N(N <= 500)和P(P >= 2N的最小素数),N是要插入到哈希表的元素个数,P是哈希表表长;第2行给出N个无重复元素的正整数,数据之间用空格间隔。

Output

按输入数据的顺序输出各数在哈希表中的存储位置 (hash表下标从0开始),数据之间以空格间隔,以平方探测方法处理冲突。

Example Input

4 11
10 6 4 15
9 11
47 7 29 11 9 84 54 20 30

Example Output

10 6 4 5
3 7 8 0 9 6 10 2 1

#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;
int main()
{
int N,P,i,j;
int hash[88];
while(~scanf("%d%d",&N,&P))
{
int key,k,mark=1;
memset(hash,0,sizeof(hash));
for(i=0; i<N; i++)
{
scanf("%d",&key);
k = key%P;
if(hash[k]!=0)
{
for(j=1;j<P;j++)
{
int di = j*j;
if(hash[(k+di)%P]==0)
{
cout<<" "<<(k+di)%P;
hash[(k+di)%P] = key;
break;
}
else if(hash[(k-di)%P]==0)
{
cout<<" "<<(k-di)%P;
hash[(k-di)%P] = key;
break;
}
}
}
else
{
hash[k] = key;
if(mark==1)
cout<<k,mark=0;
else
{
cout<<" "<<k;
}
}
}
printf("\n");
}
return 0;
}
原文地址:https://www.cnblogs.com/CCCrunner/p/11782112.html