[POJ3107] Godfather

Godfather
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 8728   Accepted: 3064

Description

Last years Chicago was full of gangster fights and strange murders. The chief of the police got really tired of all these crimes, and decided to arrest the mafia leaders.

Unfortunately, the structure of Chicago mafia is rather complicated. There are n persons known to be related to mafia. The police have traced their activity for some time, and know that some of them are communicating with each other. Based on the data collected, the chief of the police suggests that the mafia hierarchy can be represented as a tree. The head of the mafia, Godfather, is the root of the tree, and if some person is represented by a node in the tree, its direct subordinates are represented by the children of that node. For the purpose of conspiracy the gangsters only communicate with their direct subordinates and their direct master.

Unfortunately, though the police know gangsters’ communications, they do not know who is a master in any pair of communicating persons. Thus they only have an undirected tree of communications, and do not know who Godfather is.

Based on the idea that Godfather wants to have the most possible control over mafia, the chief of the police has made a suggestion that Godfather is such a person that after deleting it from the communications tree the size of the largest remaining connected component is as small as possible. Help the police to find all potential Godfathers and they will arrest them.

Input

The first line of the input file contains n — the number of persons suspected to belong to mafia (2 ≤ n ≤ 50 000). Let them be numbered from 1 to n.

The following n − 1 lines contain two integer numbers each. The pair ai, bi means that the gangster ai has communicated with the gangster bi. It is guaranteed that the gangsters’ communications form a tree.

Output

Print the numbers of all persons that are suspected to be Godfather. The numbers must be printed in the increasing order, separated by spaces.

Sample Input

6
1 2
2 3
2 5
3 4
3 6

Sample Output

2 3

Source

Northeastern Europe 2005, Northern Subregion
 

 
题解:
闲得无聊写暴力, 结果就过了,数据太水?
枚举一点都没有技术含量...
正解好像是树形DP?再想想...
刚才才发现我写的暴力好像就是树的重心...尬死了
原来这不是O(n^2)代码...长知识了...
 

 
Code:
暴力代码(树的重心)
#include <iostream>
#include <cstdio>
using namespace std;

int n;
struct edge
{
    int nxt, to;
}ed[100010];
int head[50010], cnt;
inline void add(int x, int y){ed[++cnt]=(edge){head[x], y};head[x]=cnt;}
int siz[50010];
int f[50010];
int fat[50010];
int mx=1e9;

inline void dfs(int x, int fa)
{
    siz[x] = 1;
    for (register int i = head[x]; i; i = ed[i].nxt)
    {
        int to = ed[i].to;
        if (fa == to) continue;
        fat[to] = x;
        dfs(to, x);
        siz[x] += siz[to];
    }
}

int main()
{
    scanf("%d", &n);
    for (register int i = 1; i < n; i++)
    {
        int x, y;
        scanf("%d%d", &x, &y);
        add(x, y), add(y, x);
    }
    dfs(1, 0);
    for (register int x = 1; x <= n; x ++)
    {
        int sum=0;
        for (register int i = head[x]; i; i = ed[i].nxt)
        {
            int to = ed[i].to;
            if (to == fat[x]) sum = max(sum, siz[1] - siz[x]);
            else sum = max(sum, siz[to]);
        }
        f[x] = sum;
        mx = min(mx, f[x]);
    }
    for (register int i = 1; i <= n; i ++)
    {
        if (f[i] == mx) printf("%d ", i);
    }
    return 0;
}
原文地址:https://www.cnblogs.com/BriMon/p/9262098.html