【UVa】[401]Palindromes

Palindromes

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.


A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string "3AIAE" is a mirrored string because "A" and "I" are their own reverses, and "3" and "E"are each others' reverses.


A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string "ATOYOTA" is a mirrored palindrome because if the string is read backwards, the string is the same as the original and because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string. Of course, "A""T""O", and "Y"are all their own reverses.


A list of all valid characters and their reverses is as follows.


Character Reverse Character Reverse Character Reverse
A A M M Y Y
B   N   Z 5
C   O O 1 1
D   P   2 S
E 3 Q   3 E
F   R   4  
G   S 2 5 Z
H H T T 6  
I I U U 7  
J L V V 8 8
K   W W 9  
L J X X    


Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.

Input

Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.

Output

For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.


STRING CRITERIA
" -- is not a palindrome." if the string is not a palindrome and is not a mirrored string
" -- is a regular palindrome." if the string is a palindrome and is not a mirrored string
" -- is a mirrored string." if the string is not a palindrome and is a mirrored string
" -- is a mirrored palindrome." if the string is a palindrome and is a mirrored string

Note that the output line is to include the -'s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.

In addition, after each output line, you must print an empty line.

Sample Input

NOTAPALINDROME 
ISAPALINILAPASI 
2A3MEAS 
ATOYOTA

Sample Output

NOTAPALINDROME -- is not a palindrome.
 
ISAPALINILAPASI -- is a regular palindrome.
 
2A3MEAS -- is a mirrored string.
 
ATOYOTA -- is a mirrored palindrome.


UVa的这些题目好难截图啊……


自己写的代码:

#include<stdio.h>
#include<string.h>
char Re[]="A   3  HIL JM O   2TUVWXY51SE Z  8 ";
char s[30];
char ex(char c) {
	if(c>='A'&&c<='Z')
		return Re[c-'A'];
	else
		return Re[c-'1'+26];
}
int hui(char* s,int len) {
	int i;
	for(i=0; i<(len+1)/2; i++) {
		if(s[i]!=s[len-i-1])
			return 0;
	}
	return 1;
}
int jing(char* s,int len) {
	int i;
	for(i=0; i<(len+1)/2; i++) {
		if(s[i]!=ex(s[len-i-1]))
			return 0;
	}
	return 1;
}
int main() {
	while(scanf("%s",s)!=EOF) {
		if(hui(s,strlen(s))) {
			if(jing(s,strlen(s)))
				printf("%s -- is a mirrored palindrome.\n\n",s);
			else
				printf("%s -- is a regular palindrome.\n\n",s);
		} else if(jing(s,strlen(s)))
			printf("%s -- is a mirrored string.\n\n",s);
		else
			printf("%s -- is not a palindrome.\n\n",s);
	}
	return 0;
}

起初因为最后两个printf忘了写参数,结果总是莫名其妙的程序终止

还没收到警告

最后用在线编译检查出来的……


书中标准程序:

#include<stdio.h>
#include<string.h>
#include<ctype.h>
const char* rev="A   3  HIL JM O   2TUVWXY51SE Z  8 ";
const char* msg[]= {"not a palindrome","a regular palindrome","a mirrored string","a mirrored palindrome"};
char r(char ch) {
	if(isalpha(ch))
		return rev[ch-'A'];
	return rev[ch-'0'+25];
}
int main() {
	char s[30];
	while(scanf("%s",s)==1) {
		int len = strlen(s);
		int p=1,m=1;
		for(int i=0; i<(len+1)/2; i++) {
			if(s[i]!=s[len-1-i])
				p=0;
			if(r(s[i])!=s[len-1-i])
				m=0;
		}
		printf("%s -- is %s.\n\n",s,msg[m*2+p]);
		//很有意思的输出方法 竟然通过m*2+p的式子神奇地判定了输出内容 
	}
	return 0;
}

-.-话说起初因为打错一个单词一直WA 还以为代码有错呢……


与大神的差距就是那个 m*2+p 因为没有使用这种巧妙的方法 为了好写 写了三个函数 有点繁琐了

不过思路还是很清晰的

几个if else 这点智商上的差距 不知道这辈子还能弥补上不……


题目地址:【UVa】[401]Palindromes

PS:因为UVaOJ经常打不开……所以我看以后这些题尽量在UVa上传如果不行就找其他地址
这个是华中科技大学的Virtual Judge

原文地址:https://www.cnblogs.com/BoilTask/p/12569939.html