PAT 1048 Find Coins[比较]

1048 Find Coins (25 分)

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (105​​, the total number of coins) and M (103​​, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1​​ and V2​​ (separated by a space) such that V1​​+V2​​=Mand V1​​V2​​. If such a solution is not unique, output the one with the smallest V1​​. If there is no solution, output No Solution instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

 题目大意:给出n个数,并给出一个两个数的和,判断是否存在这样的两个数,如果有相同的,输出V1较小的结果。

#include <iostream>
#include <algorithm>
#include <vector>
#include<string.h>
#include<string>
#include<cstdio>
using namespace std;

int a[100000];
int main()
{
    int n,total;
    cin>>n>>total;
    for(int i=0;i<n;i++){
        cin>>a[i];
    }
    int f=-1,s=-1;
    sort(a,a+n);//从小到大排列。
    bool flag=true;
    for(int i=0;i<n-1&&flag;i++){
        for(int j=i+1;j<n;j++){
            if(a[i]+a[j]==total){
                f=a[i];
                s=a[j];
                flag=false;break;
            }else if(a[i]+a[j]>total)break;
        }
    }
    if(f!=-1&&s!=-1)
        cout<<f<<" "<<s;
    else
        cout<<"No Solution";
    return 0;
}

//一开始写成这个样子,牛客网上通过60%,PAT上有两个测试点没通过,都是因为运行超时,不知如何解决。

下是柳神的解答,实在是叹为观止。

1.使用数组记录数字出现的个数,

2硬币面值不超过500!!!。。

原文地址:https://www.cnblogs.com/BlueBlueSea/p/9963079.html