PAT 1042 Shuffling Machine[难]

1042 Shuffling Machine (20)(20 分)

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, H1, H2, ..., H13, C1, C2, ..., C13, D1, D2, ..., D13, J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (<= 20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5
题目大意:模拟洗牌机,算上大王小王一共54张牌,给出一系列数,将i位放置到j位,输入的第一个数k表示洗牌次数。

 //不知道用什么数据结构存比较方便啊。

#include <iostream>
#include<stdio.h>
#include<map>
using namespace std;

char ch[]={'S','H','C','D'};
int pos[55];
string str[55];
map<int,string> mp;
map<int,string> mp2;
int main() {
    int ct=1;
    for(int i=0;i<4;i++){
        for(int j=1;j<14;j++){
            if(j<10)
                mp[ct++]=ch[i]+(j+'0');
            else{
                mp[ct++]=ch[i]+"1"+(j%10+'0');
                printf("%s",ch[i]+"1"+(j%10+'0'));
            }
            cout<<mp[ct-1]<<" ";
        }
    }
    mp[ct]="J1";
    mp[ct]="J2";
//    for(int i=1;i<=54;i++)
//        cout<<mp[i]<<" ";
    int k;
    cin>>k;
    for(int i=1;i<=54;i++)
        cin>>pos[i];
    if(k==0){
        for(int i=1;i<=54;i++){
        cout<<mp[i];
        if(i!=54)cout<<" ";
    }
    return 0;
    }else{
        while(k--){
            for(int i=1;i<=54;i++){
                mp2[pos[i]]=mp[i];
            }
        }
    }
    for(int i=1;i<=54;i++){
        cout<<mp2[i];
        if(i!=54)cout<<" ";
    }
    return 0;
}
View Code

// 这是我写的,十分辣鸡,完全不能AC,主要是初始化map<int,string>的时候,string的问题吗?不清楚为什么初始化map就失败了,这个保留一下。

大佬的代码:https://www.liuchuo.net/archives/2019

#include <cstdio>
using namespace std;
int main() {
    int cnt;
    scanf("%d", &cnt);
    int start[55], end[55], scan[55];
    for(int i = 1; i < 55; i++) {
        scanf("%d", &scan[i]);
        end[i] = i;
    }
    for(int i = 0; i < cnt; i++) {//洗牌过程。
        for(int j = 1; j < 55; j++)
            start[j] = end[j];//需要一个暂存(当时就是考虑到这个所以我设置了两个map)
        for(int k = 1; k < 55; k++)
            end[scan[k]] = start[k];
            //使用end数组存储,厉害了。使用其下标。并不一开始就直接使用。
    }
    char c[6] = {"SHCDJ"};
    for(int i = 1; i < 55; i++) {
        end[i] = end[i] - 1;//转换到从0开始计数。
        printf("%c%d", c[end[i]/13], end[i]%13+1);
        if(i != 54) printf(" ");
    }
    return 0;
}

//太厉害了,从来没想过是这么做,最后在进行规则的转换,搜了一下网上的博客,也大都是这么做的,学习了。

1.可以根据下标一开始进行洗牌,最后再进行输出转换。

2018-9-8更:

#include <iostream>
#include <vector>
#include <cstdio>
using namespace std;

int main() {
    int n;
    cin>>n;
    int a[55],b[55],sh[55];
    for(int i=1;i<=54;i++){
        cin>>sh[i];
    }
    for(int i=1;i<=54;i++)
        a[i]=i;
    for(int i=0;i<n;i++){
        for(int j=1;j<=54;j++)
            b[sh[j]]=a[j];
        //再将b全都赋值给a.
        for(int j=1;j<=54;j++)
            a[j]=b[j];//b才是最后的结果啊!
    }
    char ch[]={"SHCDJ"};//
    for(int i=1;i<=54;i++){
        b[i]=b[i]-1;
        cout<<ch[b[i]/13];//这个下标到底该怎么控制呢?
        //if(a[i]%13==0)cout<<"1";
        cout<<b[i]%13+1;
        if(i!=54)cout<<" ";
    }
    return 0;
}
View Code

//我写的AC的,又发现了一些问题;

1.char数组,初始化的时候可以使用{'A','C'}这样初始化,也可以使用字符串的形式初始化{"AC"},那么字符数组最后一个元素就是'\0'.

2.最后在输出的时候,一定要有每个数-1,之前没-1一直对不上号,应该-1,那么字符部分就由/13决定,数字部分就由%13+1决定。

//又学习了!

原文地址:https://www.cnblogs.com/BlueBlueSea/p/9502487.html