PAT 1045 Favorite Color Stripe[dp][难]

1045 Favorite Color Stripe (30)(30 分)

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (<=200) followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (<=10000) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7

 题目大意:找出最长公共子序列,不过是可以重复的,给的例子就是,第一个结果{2 2 1 1 1 5 6},重复了1将3忽略了,第二个是将3和多余的1忽略只计算5,第三个是计算了6,第四个是计算上了3. 

 //读了3遍题,都没看懂,绝望。看懂了题但是一点思路都没有,从来没见过这样的题,最长子序列是见过,但是不会做重复的。

 代码来自:https://www.liuchuo.net/archives/2283

#include <iostream>
#include <vector>
using namespace std;
int book[201], a[10001], dp[10001];
int main() {
    int n, m, x, l, num = 0, maxn = 0;
    scanf("%d %d", &n, &m);
    for(int i = 1; i <= m; i++) {
        scanf("%d", &x);
        book[x] = i;
    }
    scanf("%d", &l);
    //为什么要用存储放置的位置呢?因为之后要查找,如果是普通存的话,就需要一次次进行遍历!
    for(int i = 0; i < l; i++) {
        scanf("%d", &x);
        if(book[x] >= 1)
            a[num++] = book[x];
    }
    for(int i = 0; i < num; i++) {
        dp[i] = 1;
        for(int j = 0; j < i; j++)
            if(a[i] >= a[j])
                dp[i] = max(dp[i], dp[j] + 1);
        maxn = max(dp[i], maxn);
    }
    printf("%d", maxn);
    return 0;
}

//简直不要太厉害了。dp[i]表示初始化,未遍历之前最大长度为1,i是一个控制全局的指针,每次都有j指向的与i进行比较,并且之前使用book记录了下标也就是表示出现的顺序,以此来作为大小进行比较。

1.使用数组来存储出现的位置,而不是出现的数字,这很重要。

2.并且dp的思想真的好难学。

3.并且去掉干扰项 ,将所有不喜欢的颜色就不进行存储,以此形成了一个新的数组。

原文地址:https://www.cnblogs.com/BlueBlueSea/p/9475095.html